# CVE-2016-4442: rack-mini-profiler allows remote attackers to obtain sensitive information about allocated strings and objects

> Remote attackers can obtain sensitive information about allocated strings and objects due to incorrect security check ordering in the rack-mini-profiler gem.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-j5hj-fhc9-g24m

## What is CVE-2016-4442?

CVE-2016-4442 is a medium-severity vulnerability in n/a, published on 2 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The rack-mini-profiler gem before 0.10.1 for Ruby allows remote attackers to obtain sensitive information about allocated strings and objects by leveraging incorrect ordering of security checks.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-4442?

2 open source packages ship an affected version, including rack-mini-profiler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack-mini-profiler` | RubyGems | All versions | 0.10.1 |
| `rack-mini-profiler` | RubyGems | All versions | 0.10.1 |

Products: Miniprofiler Rack-Mini-Profiler.

## How do I fix CVE-2016-4442?

Upgrade rack-mini-profiler to 0.10.1 or later.

## Is CVE-2016-4442 being exploited?

There is no known exploitation of CVE-2016-4442 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4442 and fix it if it is affected.

What it is: CVE-2016-4442 is a medium-severity vulnerability in n/a, published on 2 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4442 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack-mini-profiler (RubyGems): affected all versions; fixed in 0.10.1
- rack-mini-profiler (RubyGems): affected all versions; fixed in 0.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4442/ (Markdown: https://insights.sbomify.com/CVE-2016-4442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4442
- OSV: https://osv.dev/vulnerability/CVE-2016-4442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4442/
Summaries are generated and may contain mistakes; the official description above is the record.
