# CVE-2016-4461: Apache Struts forced double OGNL evaluation

> Remote attackers can execute arbitrary code via forced double OGNL evaluation in Apache Struts tag attributes.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-864w-r5qj-h6fj

## What is CVE-2016-4461?

CVE-2016-4461 is a high-severity code injection vulnerability in Apache Struts, published on 16 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Struts 2.x before 2.3.29 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-0785.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-4461?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.29 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.29 |

Products: Apache Struts, Netapp Oncommand Balance.

## How do I fix CVE-2016-4461?

Upgrade org.apache.struts:struts2-core to 2.3.29 or later.

## Is CVE-2016-4461 being exploited?

There is no known exploitation of CVE-2016-4461 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4461 and fix it if it is affected.

What it is: CVE-2016-4461 is a high-severity code injection vulnerability in Apache Struts, published on 16 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4461 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.29
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4461/ (Markdown: https://insights.sbomify.com/CVE-2016-4461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4461
- OSV: https://osv.dev/vulnerability/CVE-2016-4461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4461/
Summaries are generated and may contain mistakes; the official description above is the record.
