CVE-2016-4464 High severity vulnerability that affects org.apache.cxf.fediz:fediz-spring and org.apache.cxf.fediz:fediz-spring2
Attackers can bypass SAML audience restrictions in Apache CXF Fediz by using crafted tokens with trusted signatures, potentially gaining unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-4464?
CVE-2016-4464 is a critical vulnerability in n/a, published on 21 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The application plugins in Apache CXF Fediz 1.2.x before 1.2.3 and 1.3.x before 1.3.1 do not match SAML AudienceRestriction values against configured audience URIs, which might allow remote attackers to have bypass intended restrictions and have unspecified other impact via a crafted SAML token with a trusted signature.
Weakness: CWE-284
Which versions are affected by CVE-2016-4464?
8 open source packages ship an affected version, including org.apache.cxf.fediz:fediz-spring and org.apache.cxf.fediz:fediz-spring2. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cxf.fediz:fediz-spring Maven | From 1.2.0 | 1.2.3 |
org.apache.cxf.fediz:fediz-spring Maven | From 1.2.0 | 1.2.3 |
org.apache.cxf.fediz:fediz-spring Maven | From 1.3.0 | 1.3.1 |
org.apache.cxf.fediz:fediz-spring Maven | From 1.3.0 | 1.3.1 |
org.apache.cxf.fediz:fediz-spring2 Maven | From 1.2.0 | 1.2.3 |
org.apache.cxf.fediz:fediz-spring2 Maven | From 1.2.0 | 1.2.3 |
2 more packages
org.apache.cxf.fediz:fediz-spring2 Maven | From 1.3.0 | 1.3.1 |
org.apache.cxf.fediz:fediz-spring2 Maven | From 1.3.0 | 1.3.1 |
Products include Apache Cxf Fediz.
How do I fix CVE-2016-4464?
Upgrade org.apache.cxf.fediz:fediz-spring to a fixed version for your release line: 1.2.3 or 1.3.1.
Is CVE-2016-4464 being exploited?
There is no known exploitation of CVE-2016-4464 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2017-12631 Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3
- CVE-2017-7661 Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, and org.apache.cxf.fediz:fediz-spring2
- CVE-2017-7662 Cross-Site Request Forgery in Apache CXF Fediz
- CVE-2018-8038 High severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3
- CVE-2015-5175 Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks
Sources
Also known as GHSA-qpwj-mvv7-v3m9, MGASA-2016-0243.