CVE-2016-4465 Apache Struts vulnerable to possible DoS attack when using URLValidator
Remote attackers can cause a denial of service in Apache Struts by submitting a null value for a URL field.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-4465?
CVE-2016-4465 is a medium-severity denial of service vulnerability in Apache Struts, published on 4 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The URLValidator class in Apache Struts 2 2.3.20 through 2.3.28.1 and 2.5.x before 2.5.1 allows remote attackers to cause a denial of service via a null value for a URL field.
Weakness: CWE-20
Which versions are affected by CVE-2016-4465?
4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | From 2.3.20 | 2.3.29 |
org.apache.struts:struts2-core Maven | From 2.3.20 | 2.3.29 |
org.apache.struts:struts2-core Maven | From 2.5.0 | 2.5.13 |
org.apache.struts:struts2-core Maven | From 2.5.0 | 2.5.13 |
Products include Apache Struts.
How do I fix CVE-2016-4465?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.29 or 2.5.13.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2016-4465 being exploited?
There is no known exploitation of CVE-2016-4465 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-xg75-68x3-7p3q.