# CVE-2016-4567: MediaElement Vulnerable to Reflected XSS

> Remote attackers can inject arbitrary web script or HTML via the jsinitfunction parameter in MediaElement.js, affecting WordPress installations.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4567, GHSA-277w-qpxr-2549, UBUNTU-CVE-2016-4567

## What is CVE-2016-4567?

CVE-2016-4567 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 22 May 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-4567?

6 open source packages ship an affected version, including contao-components/mediaelement, contao/core and mediaelement. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao-components/mediaelement` | Packagist | From 2.14.2 | 2.21.1 |
| `contao-components/mediaelement` | Packagist | From 2.14.2 | 2.21.1 |
| `contao/core` | Packagist | From 3.0.0 | 3.5.15 |
| `contao/core` | Packagist | From 3.0.0 | 3.5.15 |
| `mediaelement` | npm | All versions | 2.11.1 |
| `mediaelement` | npm | All versions | 2.11.1 |

Products: Mediaelementjs Mediaelement.js, Wordpress Wordpress.

## How do I fix CVE-2016-4567?

Upgrade contao-components/mediaelement to 2.21.1 or later.

## Is CVE-2016-4567 being exploited?

There is no known exploitation of CVE-2016-4567 in the wild and no public exploit code.

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2022-4699](https://insights.sbomify.com/CVE-2022-4699/): MediaElement.js – HTML5 Video & Audio Player <= 4.2.8 - Contributor+ Stored XSS via Shortcode (medium 5.4)
- [CVE-2013-1967](https://insights.sbomify.com/CVE-2013-1967/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4567 and fix it if it is affected.

What it is: CVE-2016-4567 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 22 May 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-4567 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao-components/mediaelement (Packagist): affected from 2.14.2; fixed in 2.21.1
- contao-components/mediaelement (Packagist): affected from 2.14.2; fixed in 2.21.1
- contao/core (Packagist): affected from 3.0.0; fixed in 3.5.15
- contao/core (Packagist): affected from 3.0.0; fixed in 3.5.15
- mediaelement (npm): affected all versions; fixed in 2.11.1
- mediaelement (npm): affected all versions; fixed in 2.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4567/ (Markdown: https://insights.sbomify.com/CVE-2016-4567/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4567
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4567
- OSV: https://osv.dev/vulnerability/CVE-2016-4567

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4567/
Summaries are generated and may contain mistakes; the official description above is the record.
