CVE-2016-4793 CakePHP allows remote attackers to spoof their IP
Remote attackers can spoof their IP address by manipulating the CLIENT-IP HTTP header in CakePHP applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-4793?
CVE-2016-4793 is a high-severity vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
Weakness: CWE-20
Which versions are affected by CVE-2016-4793?
12 open source packages ship an affected version, including cakephp/cakephp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cakephp/cakephp Packagist | From 1.2.0 | 2.6.13 |
cakephp/cakephp Packagist | From 1.2.0 | 2.6.13 |
cakephp/cakephp Packagist | From 2.7.0-rc1 | 2.7.11 |
cakephp/cakephp Packagist | From 2.7.0-rc1 | 2.7.11 |
cakephp/cakephp Packagist | From 2.8.0-rc1 | 2.8.2 |
cakephp/cakephp Packagist | From 2.8.0-rc1 | 2.8.2 |
6 more packages
cakephp/cakephp Packagist | From 3.0.0-rc1 | 3.0.17 |
cakephp/cakephp Packagist | From 3.0.0-rc1 | 3.0.17 |
cakephp/cakephp Packagist | From 3.1.0-beta1 | 3.1.12 |
cakephp/cakephp Packagist | From 3.1.0-beta1 | 3.1.12 |
cakephp/cakephp Packagist | From 3.2.0-rc1 | 3.2.5 |
cakephp/cakephp Packagist | From 3.2.0-rc1 | 3.2.5 |
Products include Cakephp Cakephp.
How do I fix CVE-2016-4793?
Upgrade cakephp/cakephp to a fixed version for your release line: 2.6.13, 2.7.11, 2.8.2 or 3.0.17.
Is CVE-2016-4793 being exploited?
There is no known exploitation of CVE-2016-4793 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in n/a
- CVE-2023-22727 Database Query::offset() and limit() vulnerable to SQL injection in cakephp
- CVE-2020-35239 CakePHP allows method override parameters to bypass CSRF checks
- CVE-2015-8379 CakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameter
- CVE-2019-11458 Unsafe deserialization in SmtpTransport in CakePHP
- CVE-2026-23643 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
Sources
Also known as DEBIAN-CVE-2016-4793, DLA-835-1, GHSA-j8p3-8m69-2hqq, UBUNTU-CVE-2016-4793.