# CVE-2016-4793: CakePHP allows remote attackers to spoof their IP

> Remote attackers can spoof their IP address by manipulating the CLIENT-IP HTTP header in CakePHP applications.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4793, DLA-835-1, GHSA-j8p3-8m69-2hqq, UBUNTU-CVE-2016-4793

## What is CVE-2016-4793?

CVE-2016-4793 is a high-severity vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-4793?

12 open source packages ship an affected version, including cakephp/cakephp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cakephp/cakephp` | Packagist | From 1.2.0 | 2.6.13 |
| `cakephp/cakephp` | Packagist | From 1.2.0 | 2.6.13 |
| `cakephp/cakephp` | Packagist | From 2.7.0-rc1 | 2.7.11 |
| `cakephp/cakephp` | Packagist | From 2.7.0-rc1 | 2.7.11 |
| `cakephp/cakephp` | Packagist | From 2.8.0-rc1 | 2.8.2 |
| `cakephp/cakephp` | Packagist | From 2.8.0-rc1 | 2.8.2 |
| `cakephp/cakephp` | Packagist | From 3.0.0-rc1 | 3.0.17 |
| `cakephp/cakephp` | Packagist | From 3.0.0-rc1 | 3.0.17 |
| `cakephp/cakephp` | Packagist | From 3.1.0-beta1 | 3.1.12 |
| `cakephp/cakephp` | Packagist | From 3.1.0-beta1 | 3.1.12 |
| `cakephp/cakephp` | Packagist | From 3.2.0-rc1 | 3.2.5 |
| `cakephp/cakephp` | Packagist | From 3.2.0-rc1 | 3.2.5 |

Products: Cakephp Cakephp.

## How do I fix CVE-2016-4793?

Upgrade cakephp/cakephp to a fixed version for your release line: 2.6.13, 2.7.11, 2.8.2 or 3.0.17.

## Is CVE-2016-4793 being exploited?

There is no known exploitation of CVE-2016-4793 in the wild and no public exploit code.

Public exploit code:

- CakePHP Framework 3.2.4 - IP Spoofing (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2023-22727](https://insights.sbomify.com/CVE-2023-22727/): Database Query::offset() and limit() vulnerable to SQL injection in cakephp (critical 9.8)
- [CVE-2020-35239](https://insights.sbomify.com/CVE-2020-35239/): CakePHP allows method override parameters to bypass CSRF checks (high 8.8)
- [CVE-2015-8379](https://insights.sbomify.com/CVE-2015-8379/): CakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameter (high 8.8)
- [CVE-2019-11458](https://insights.sbomify.com/CVE-2019-11458/): Unsafe deserialization in SmtpTransport in CakePHP (high 7.5)
- [CVE-2026-23643](https://insights.sbomify.com/CVE-2026-23643/): CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4793 and fix it if it is affected.

What it is: CVE-2016-4793 is a high-severity vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4793 in the wild and no public exploit code.

Affected packages and fixed versions:
- cakephp/cakephp (Packagist): affected from 1.2.0; fixed in 2.6.13
- cakephp/cakephp (Packagist): affected from 1.2.0; fixed in 2.6.13
- cakephp/cakephp (Packagist): affected from 2.7.0-rc1; fixed in 2.7.11
- cakephp/cakephp (Packagist): affected from 2.7.0-rc1; fixed in 2.7.11
- cakephp/cakephp (Packagist): affected from 2.8.0-rc1; fixed in 2.8.2
- cakephp/cakephp (Packagist): affected from 2.8.0-rc1; fixed in 2.8.2
- cakephp/cakephp (Packagist): affected from 3.0.0-rc1; fixed in 3.0.17
- cakephp/cakephp (Packagist): affected from 3.0.0-rc1; fixed in 3.0.17
- cakephp/cakephp (Packagist): affected from 3.1.0-beta1; fixed in 3.1.12
- cakephp/cakephp (Packagist): affected from 3.1.0-beta1; fixed in 3.1.12
- cakephp/cakephp (Packagist): affected from 3.2.0-rc1; fixed in 3.2.5
- cakephp/cakephp (Packagist): affected from 3.2.0-rc1; fixed in 3.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4793/ (Markdown: https://insights.sbomify.com/CVE-2016-4793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4793
- OSV: https://osv.dev/vulnerability/CVE-2016-4793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4793/
Summaries are generated and may contain mistakes; the official description above is the record.
