# CVE-2016-4800: Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request

> Remote attackers can bypass protected resource restrictions in Eclipse Jetty on Windows via crafted URLs with escaped characters.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-872g-2h8h-362q

## What is CVE-2016-4800?

CVE-2016-4800 is a critical path traversal vulnerability in Eclipse Jetty, published on 13 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The path normalization mechanism in PathResource class in Eclipse Jetty 9.3.x before 9.3.9 on Windows allows remote attackers to bypass protected resource restrictions and other security constraints via a URL with certain escaped characters, related to backslashes.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-4800?

2 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.3.0 | 9.3.9 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.3.0 | 9.3.9 |

Products: Eclipse Jetty.

## How do I fix CVE-2016-4800?

Upgrade org.eclipse.jetty:jetty-server to 9.3.9 or later.

## Is CVE-2016-4800 being exploited?

There is no known exploitation of CVE-2016-4800 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Jetty

- [CVE-2019-17638](https://insights.sbomify.com/CVE-2019-17638/): Operation on a Resource after Expiration or Release in Jetty Server (critical 9.4)
- [CVE-2018-12538](https://insights.sbomify.com/CVE-2018-12538/): Access and integrity issue within Eclipse Jetty (high 8.8)
- [CVE-2026-10050](https://insights.sbomify.com/CVE-2026-10050/): Digest authentication lossy encoding (high 8.7)
- [CVE-2025-5115](https://insights.sbomify.com/CVE-2025-5115/): MadeYouReset HTTP/2 vulnerability (high 7.7)
- [CVE-2024-7708](https://insights.sbomify.com/CVE-2024-7708/): Eclipse Jetty: DoS attack triggering OutOfMemory with 100-Continue requests (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4800 and fix it if it is affected.

What it is: CVE-2016-4800 is a critical path traversal vulnerability in Eclipse Jetty, published on 13 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4800 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected from 9.3.0; fixed in 9.3.9
- org.eclipse.jetty:jetty-server (Maven): affected from 9.3.0; fixed in 9.3.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4800/ (Markdown: https://insights.sbomify.com/CVE-2016-4800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4800
- OSV: https://osv.dev/vulnerability/CVE-2016-4800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4800/
Summaries are generated and may contain mistakes; the official description above is the record.
