{"answers":{"affected":"3 open source packages ship an affected version, including web2py. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-4808 exists.","fix":"Upgrade web2py to 2.14.6 or later.","what":"CVE-2016-4808 is a high-severity vulnerability in n/a, published on 11 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-4808 and fix it if it is affected.\n\nWhat it is: CVE-2016-4808 is a high-severity vulnerability in n/a, published on 11 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-4808 exists.\n\nAffected packages and fixed versions:\n- web2py (PyPI): affected all versions; fixed in 2.14.6\n- web2py (PyPI): affected all versions; fixed in 2.14.6\n- web2py (PyPI): affected all versions; fixed in 2.14.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-4808/ (Markdown: https://insights.sbomify.com/CVE-2016-4808/index.md)","id":"CVE-2016-4808","markdown":"https://insights.sbomify.com/CVE-2016-4808/index.md","name":"CVE-2016-4808","record":{"aliases":["GHSA-gp69-xcm6-ffqj","PYSEC-2026-1061"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Web2py framework","requires_auth":"none","summary":"Attackers can trick logged-in users into performing unwanted actions like disabling applications via crafted URLs in Web2py.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"web2py","vendor":"web2py"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Web2py versions 2.14.5 and below was affected by CSRF (Cross Site Request Forgery) vulnerability, which allows an attacker to trick a logged in user to perform some unwanted actions i.e An attacker can trick an victim to disable the installed application just by sending a URL to victim.","ecosystems":["PyPI"],"exploits":{"exploitdb":1,"first_seen":"2016-05-16","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2016-05-16","kind":"exploitdb","ref":"39821","stars":null,"title":"Web2py 2.14.5 - Multiple Vulnerabilities"}],"tier":"weaponised"},"has_fix":true,"headline":"Web2py Cross-Site Request Forgery vulnerability","id":"CVE-2016-4808","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"csrf","year":"2016"},"n_packages":3,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-4809"},"packages":[{"ecosystem":"PyPI","fixed":["2.14.6"],"introduced":["0"],"last_affected":[],"package":"web2py","purl":null,"source":"GHSA-gp69-xcm6-ffqj"},{"ecosystem":"PyPI","fixed":["2.14.6"],"introduced":["0"],"last_affected":[],"package":"web2py","purl":"pkg:pypi/web2py","source":"GHSA-gp69-xcm6-ffqj"},{"ecosystem":"PyPI","fixed":["2.14.6"],"introduced":["0"],"last_affected":[],"package":"web2py","purl":"pkg:pypi/web2py","source":"PYSEC-2026-1061"}],"prev":{"headline":"Web2py Reflected XSS vulnerability","id":"CVE-2016-4807"},"products":["n/a"],"published":"2017-01-11","related":[{"cvss_score":9.8,"headline":"Command injection in web2py","id":"CVE-2023-45158","kev_date_added":null,"published":"2023-10-16"},{"cvss_score":9.8,"headline":"web2py remote code execution via hardcoded encryption key in session.connect function","id":"CVE-2016-3953","kev_date_added":null,"published":"2018-02-06"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2016-3957","kev_date_added":null,"published":"2018-02-06"},{"cvss_score":9.8,"headline":"web2py is vulnerable to password brute-force attack","id":"CVE-2016-10321","kev_date_added":null,"published":"2017-04-10"},{"cvss_score":7.8,"headline":"Information disclosure in n/a","id":"CVE-2016-3952","kev_date_added":null,"published":"2018-02-06"},{"cvss_score":7.5,"headline":"Path traversal in n/a","id":"CVE-2016-4806","kev_date_added":null,"published":"2017-01-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can trick logged-in users into performing unwanted actions like disabling applications via crafted URLs in Web2py.","url":"https://insights.sbomify.com/CVE-2016-4808/"}