# CVE-2016-4808: Web2py Cross-Site Request Forgery vulnerability

> Attackers can trick logged-in users into performing unwanted actions like disabling applications via crafted URLs in Web2py.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-gp69-xcm6-ffqj, PYSEC-2026-1061

## What is CVE-2016-4808?

CVE-2016-4808 is a high-severity vulnerability in n/a, published on 11 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Web2py versions 2.14.5 and below was affected by CSRF (Cross Site Request Forgery) vulnerability, which allows an attacker to trick a logged in user to perform some unwanted actions i.e An attacker can trick an victim to disable the installed application just by sending a URL to victim.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2016-4808?

3 open source packages ship an affected version, including web2py. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `web2py` | PyPI | All versions | 2.14.6 |
| `web2py` | PyPI | All versions | 2.14.6 |
| `web2py` | PyPI | All versions | 2.14.6 |

Products: Web2py Web2py.

## How do I fix CVE-2016-4808?

Upgrade web2py to 2.14.6 or later.

## Is CVE-2016-4808 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-4808 exists.

Public exploit code:

- Web2py 2.14.5 - Multiple Vulnerabilities (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2023-45158](https://insights.sbomify.com/CVE-2023-45158/): Command injection in web2py (critical 9.8)
- [CVE-2016-3953](https://insights.sbomify.com/CVE-2016-3953/): web2py remote code execution via hardcoded encryption key in session.connect function (critical 9.8)
- [CVE-2016-3957](https://insights.sbomify.com/CVE-2016-3957/): Deserialization in n/a (critical 9.8)
- [CVE-2016-10321](https://insights.sbomify.com/CVE-2016-10321/): web2py is vulnerable to password brute-force attack (critical 9.8)
- [CVE-2016-3952](https://insights.sbomify.com/CVE-2016-3952/): Information disclosure in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4808 and fix it if it is affected.

What it is: CVE-2016-4808 is a high-severity vulnerability in n/a, published on 11 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-4808 exists.

Affected packages and fixed versions:
- web2py (PyPI): affected all versions; fixed in 2.14.6
- web2py (PyPI): affected all versions; fixed in 2.14.6
- web2py (PyPI): affected all versions; fixed in 2.14.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4808/ (Markdown: https://insights.sbomify.com/CVE-2016-4808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4808
- OSV: https://osv.dev/vulnerability/CVE-2016-4808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4808/
Summaries are generated and may contain mistakes; the official description above is the record.
