# CVE-2016-4855: ADOdb Cross-site scripting vulnerability in old test script

> Remote attackers can inject arbitrary web script or HTML into applications using the ADOdb library, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 May 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4855, GHSA-hhfw-xxhm-pf32, UBUNTU-CVE-2016-4855

## What is CVE-2016-4855?

CVE-2016-4855 is a medium-severity cross-site scripting vulnerability in ADOdb, published on 12 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-4855?

2 open source packages ship an affected version, including adodb/adodb-php. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `adodb/adodb-php` | Packagist | All versions | 5.20.6 |
| `adodb/adodb-php` | Packagist | All versions | 5.20.6 |

Products: Adodb Project Adodb.

## How do I fix CVE-2016-4855?

Upgrade adodb/adodb-php to 5.20.6 or later.

## Is CVE-2016-4855 being exploited?

There is no known exploitation of CVE-2016-4855 in the wild and no public exploit code.

## Other vulnerabilities in ADOdb

- [CVE-2016-7405](https://insights.sbomify.com/CVE-2016-7405/): ADOdb Library SQL Injection (critical 9.8)
- [CVE-2021-3850](https://insights.sbomify.com/CVE-2021-3850/): Authentication Bypass by Primary Weakness in adodb/adodb (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4855 and fix it if it is affected.

What it is: CVE-2016-4855 is a medium-severity cross-site scripting vulnerability in ADOdb, published on 12 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-4855 in the wild and no public exploit code.

Affected packages and fixed versions:
- adodb/adodb-php (Packagist): affected all versions; fixed in 5.20.6
- adodb/adodb-php (Packagist): affected all versions; fixed in 5.20.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4855/ (Markdown: https://insights.sbomify.com/CVE-2016-4855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4855
- OSV: https://osv.dev/vulnerability/CVE-2016-4855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4855/
Summaries are generated and may contain mistakes; the official description above is the record.
