{"answers":{"affected":"4 open source packages ship an affected version, including io.netty:netty-handler. It affects 4 products.","exploited":"There is no known exploitation of CVE-2016-4970 in the wild and no public exploit code.","fix":"Upgrade io.netty:netty-handler to a fixed version for your release line: 4.0.37.Final or 4.1.1.Final.","what":"CVE-2016-4970 is a high-severity denial of service vulnerability in Netty Netty, published on 13 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-4970 and fix it if it is affected.\n\nWhat it is: CVE-2016-4970 is a high-severity denial of service vulnerability in Netty Netty, published on 13 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-4970 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.netty:netty-handler (Maven): affected from 4.0.0.Alpha1; fixed in 4.0.37.Final\n- io.netty:netty-handler (Maven): affected from 4.0.0.Alpha1; fixed in 4.0.37.Final\n- io.netty:netty-handler (Maven): affected from 4.1.0.Beta1; fixed in 4.1.1.Final\n- io.netty:netty-handler (Maven): affected from 4.1.0.Beta1; fixed in 4.1.1.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-4970/ (Markdown: https://insights.sbomify.com/CVE-2016-4970/index.md)","id":"CVE-2016-4970","markdown":"https://insights.sbomify.com/CVE-2016-4970/index.md","name":"CVE-2016-4970","record":{"aliases":["DEBIAN-CVE-2016-4970","GHSA-rv63-gqm8-9w8q","MGASA-2018-0485","UBUNTU-CVE-2016-4970"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Netty Java library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via an infinite loop in the Netty SSL engine, requiring an upgrade to the library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cassandra","vendor":"apache"},{"product":"netty","vendor":"netty"},{"product":"jboss_data_grid","vendor":"redhat"},{"product":"jboss_middleware_text-only_advisories","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Loop with Unreachable Exit Condition in Netty","id":"CVE-2016-4970","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"netty:netty","products":["netty:netty"],"type":"denial_of_service","year":"2016"},"n_packages":4,"n_references":9,"next":{"headline":"Path traversal in n/a","id":"CVE-2016-4971"},"packages":[{"ecosystem":"Maven","fixed":["4.0.37.Final"],"introduced":["4.0.0.Alpha1"],"last_affected":[],"package":"io.netty:netty-handler","purl":null,"source":"GHSA-rv63-gqm8-9w8q"},{"ecosystem":"Maven","fixed":["4.0.37.Final"],"introduced":["4.0.0.Alpha1"],"last_affected":[],"package":"io.netty:netty-handler","purl":"pkg:maven/io.netty/netty-handler","source":"GHSA-rv63-gqm8-9w8q"},{"ecosystem":"Maven","fixed":["4.1.1.Final"],"introduced":["4.1.0.Beta1"],"last_affected":[],"package":"io.netty:netty-handler","purl":null,"source":"GHSA-rv63-gqm8-9w8q"},{"ecosystem":"Maven","fixed":["4.1.1.Final"],"introduced":["4.1.0.Beta1"],"last_affected":[],"package":"io.netty:netty-handler","purl":"pkg:maven/io.netty/netty-handler","source":"GHSA-rv63-gqm8-9w8q"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-4969"},"products":["n/a"],"published":"2017-04-13","related":[{"cvss_score":9.8,"headline":"Oracle Java SE and JRockit Unspecified","id":"CVE-2016-3427","kev_date_added":"2023-05-12","published":"2016-04-21"},{"cvss_score":9.8,"headline":"Missing Authentication for Critical Function in Apache Cassandra","id":"CVE-2018-8016","kev_date_added":null,"published":"2018-06-28"},{"cvss_score":9.1,"headline":"Remote code execution for scripted UDFs","id":"CVE-2021-44521","kev_date_added":null,"published":"2022-02-11"},{"cvss_score":8.8,"headline":"Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass","id":"CVE-2026-27314","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":8.8,"headline":"Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)","id":"CVE-2025-26467","kev_date_added":null,"published":"2025-08-25"},{"cvss_score":8.8,"headline":"Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions","id":"CVE-2025-23015","kev_date_added":null,"published":"2025-02-04"},{"cvss_score":7.8,"headline":"Apache Cassandra: Privilege escalation when enabling FQL/Audit logs","id":"CVE-2023-30601","kev_date_added":null,"published":"2023-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via an infinite loop in the Netty SSL engine, requiring an upgrade to the library.","url":"https://insights.sbomify.com/CVE-2016-4970/"}