# CVE-2016-4970: Loop with Unreachable Exit Condition in Netty

> Remote attackers can cause a denial of service via an infinite loop in the Netty SSL engine, requiring an upgrade to the library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4970, GHSA-rv63-gqm8-9w8q, MGASA-2018-0485, UBUNTU-CVE-2016-4970

## What is CVE-2016-4970?

CVE-2016-4970 is a high-severity denial of service vulnerability in Netty Netty, published on 13 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2016-4970?

4 open source packages ship an affected version, including io.netty:netty-handler. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-handler` | Maven | From 4.0.0.Alpha1 | 4.0.37.Final |
| `io.netty:netty-handler` | Maven | From 4.0.0.Alpha1 | 4.0.37.Final |
| `io.netty:netty-handler` | Maven | From 4.1.0.Beta1 | 4.1.1.Final |
| `io.netty:netty-handler` | Maven | From 4.1.0.Beta1 | 4.1.1.Final |

Products: Apache Cassandra, Netty Netty, Redhat Jboss Data Grid, Redhat Jboss Middleware Text-Only Advisories.

## How do I fix CVE-2016-4970?

Upgrade io.netty:netty-handler to a fixed version for your release line: 4.0.37.Final or 4.1.1.Final.

## Is CVE-2016-4970 being exploited?

There is no known exploitation of CVE-2016-4970 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2016-3427](https://insights.sbomify.com/CVE-2016-3427/): Oracle Java SE and JRockit Unspecified (critical 9.8, exploited in the wild)
- [CVE-2018-8016](https://insights.sbomify.com/CVE-2018-8016/): Missing Authentication for Critical Function in Apache Cassandra (critical 9.8)
- [CVE-2021-44521](https://insights.sbomify.com/CVE-2021-44521/): Remote code execution for scripted UDFs (critical 9.1)
- [CVE-2026-27314](https://insights.sbomify.com/CVE-2026-27314/): Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass (high 8.8)
- [CVE-2025-26467](https://insights.sbomify.com/CVE-2025-26467/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4970 and fix it if it is affected.

What it is: CVE-2016-4970 is a high-severity denial of service vulnerability in Netty Netty, published on 13 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4970 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-handler (Maven): affected from 4.0.0.Alpha1; fixed in 4.0.37.Final
- io.netty:netty-handler (Maven): affected from 4.0.0.Alpha1; fixed in 4.0.37.Final
- io.netty:netty-handler (Maven): affected from 4.1.0.Beta1; fixed in 4.1.1.Final
- io.netty:netty-handler (Maven): affected from 4.1.0.Beta1; fixed in 4.1.1.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4970/ (Markdown: https://insights.sbomify.com/CVE-2016-4970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4970
- OSV: https://osv.dev/vulnerability/CVE-2016-4970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4970/
Summaries are generated and may contain mistakes; the official description above is the record.
