CVE-2016-4972 OpenStack Murano Code Execution
Remote attackers can execute arbitrary code by exploiting unsafe YAML deserialization in OpenStack Murano components.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-4972?
CVE-2016-4972 is a critical unsafe deserialization vulnerability in n/a, published on 26 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenStack Murano before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), Murano-dashboard before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), and python-muranoclient before 0.7.3 (liberty) and 0.8.x before 0.8.5 (mitaka) improperly use loaders inherited from yaml.Loader when parsing MuranoPL and UI files, which allows remote attackers to create arbitrary Python objects and execute arbitrary code via crafted extended YAML tags in UI definitions in packages.
Weakness: CWE-20
Which versions are affected by CVE-2016-4972?
13 open source packages ship an affected version, including murano-dashboard, murano and python-muranoclient. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
murano-dashboard PyPI | All versions | 1.0.3 |
murano-dashboard PyPI | All versions | 1.0.3 |
murano-dashboard PyPI | From 2.0.0 | 2.0.1 |
murano-dashboard PyPI | From 2.0.0 | 2.0.1 |
murano-dashboard PyPI | From 2.0.0 | 2.0.1 |
murano PyPI | All versions | 1.0.3 |
7 more packages
murano PyPI | All versions | 1.0.3 |
murano PyPI | All versions | 1.0.3 |
python-muranoclient PyPI | All versions | 0.7.3, 0.8.5 |
python-muranoclient PyPI | All versions | 0.7.3 |
python-muranoclient PyPI | All versions | 0.7.3 |
python-muranoclient PyPI | From 0.8.0 | 0.8.5 |
python-muranoclient PyPI | From 0.8.0 | 0.8.5 |
Products include Openstack Mitaka-Murano, Openstack Murano, Openstack Murano-Dashboard, Openstack Python-Muranoclient.
How do I fix CVE-2016-4972?
Upgrade murano-dashboard to a fixed version for your release line: 1.0.3 or 2.0.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2016-4972 being exploited?
There is no known exploitation of CVE-2016-4972 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2016-4972, GHSA-87r7-q54j-f9qg, PYSEC-2016-22, PYSEC-2026-429, PYSEC-2026-430, UBUNTU-CVE-2016-4972.