# CVE-2016-4972: OpenStack Murano Code Execution

> Remote attackers can execute arbitrary code by exploiting unsafe YAML deserialization in OpenStack Murano components.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4972, GHSA-87r7-q54j-f9qg, PYSEC-2016-22, PYSEC-2026-429, PYSEC-2026-430, UBUNTU-CVE-2016-4972

## What is CVE-2016-4972?

CVE-2016-4972 is a critical unsafe deserialization vulnerability in n/a, published on 26 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenStack Murano before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), Murano-dashboard before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), and python-muranoclient before 0.7.3 (liberty) and 0.8.x before 0.8.5 (mitaka) improperly use loaders inherited from yaml.Loader when parsing MuranoPL and UI files, which allows remote attackers to create arbitrary Python objects and execute arbitrary code via crafted extended YAML tags in UI definitions in packages.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-4972?

13 open source packages ship an affected version, including murano-dashboard, murano and python-muranoclient. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `murano-dashboard` | PyPI | All versions | 1.0.3 |
| `murano-dashboard` | PyPI | All versions | 1.0.3 |
| `murano-dashboard` | PyPI | From 2.0.0 | 2.0.1 |
| `murano-dashboard` | PyPI | From 2.0.0 | 2.0.1 |
| `murano-dashboard` | PyPI | From 2.0.0 | 2.0.1 |
| `murano` | PyPI | All versions | 1.0.3 |
| `murano` | PyPI | All versions | 1.0.3 |
| `murano` | PyPI | All versions | 1.0.3 |
| `python-muranoclient` | PyPI | All versions | 0.7.3, 0.8.5 |
| `python-muranoclient` | PyPI | All versions | 0.7.3 |
| `python-muranoclient` | PyPI | All versions | 0.7.3 |
| `python-muranoclient` | PyPI | From 0.8.0 | 0.8.5 |
| `python-muranoclient` | PyPI | From 0.8.0 | 0.8.5 |

Products: Openstack Mitaka-Murano, Openstack Murano, Openstack Murano-Dashboard, Openstack Python-Muranoclient.

## How do I fix CVE-2016-4972?

Upgrade murano-dashboard to a fixed version for your release line: 1.0.3 or 2.0.1.

## Is CVE-2016-4972 being exploited?

There is no known exploitation of CVE-2016-4972 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4972 and fix it if it is affected.

What it is: CVE-2016-4972 is a critical unsafe deserialization vulnerability in n/a, published on 26 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4972 in the wild and no public exploit code.

Affected packages and fixed versions:
- murano-dashboard (PyPI): affected all versions; fixed in 1.0.3
- murano-dashboard (PyPI): affected all versions; fixed in 1.0.3
- murano-dashboard (PyPI): affected from 2.0.0; fixed in 2.0.1
- murano-dashboard (PyPI): affected from 2.0.0; fixed in 2.0.1
- murano-dashboard (PyPI): affected from 2.0.0; fixed in 2.0.1
- murano (PyPI): affected all versions; fixed in 1.0.3
- murano (PyPI): affected all versions; fixed in 1.0.3
- murano (PyPI): affected all versions; fixed in 1.0.3
- python-muranoclient (PyPI): affected all versions; fixed in 0.7.3, 0.8.5
- python-muranoclient (PyPI): affected all versions; fixed in 0.7.3
- python-muranoclient (PyPI): affected all versions; fixed in 0.7.3
- python-muranoclient (PyPI): affected from 0.8.0; fixed in 0.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4972/ (Markdown: https://insights.sbomify.com/CVE-2016-4972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4972
- OSV: https://osv.dev/vulnerability/CVE-2016-4972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4972/
Summaries are generated and may contain mistakes; the official description above is the record.
