# CVE-2016-4976: Apache Ambari reveals administrator passwords

> Local attackers can read KDC administrator passwords from process listings in Apache Ambari, exposing sensitive credentials.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-q3pw-6vf2-66hf

## What is CVE-2016-4976?

CVE-2016-4976 is a medium-severity vulnerability in n/a, published on 29 Mar 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apache Ambari 2.x before 2.4.0 includes KDC administrator passwords on the kadmin command line, which allows local users to obtain sensitive information via a process listing.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-4976?

2 open source packages ship an affected version, including org.apache.ambari:ambari. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ambari:ambari` | Maven | From 2.0.0 | 2.4.0 |
| `org.apache.ambari:ambari` | Maven | From 2.0.0 | 2.4.0 |

Products: Apache Ambari.

## How do I fix CVE-2016-4976?

Upgrade org.apache.ambari:ambari to 2.4.0 or later.

## Is CVE-2016-4976 being exploited?

There is no known exploitation of CVE-2016-4976 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-5642](https://insights.sbomify.com/CVE-2017-5642/): Misconfiguration in Apache Ambari (critical 9.8)
- [CVE-2014-3582](https://insights.sbomify.com/CVE-2014-3582/): Command injection in n/a (critical 9.8)
- [CVE-2016-6807](https://insights.sbomify.com/CVE-2016-6807/): Apache Ambari Improper Access Control (critical 9.8)
- [CVE-2024-51941](https://insights.sbomify.com/CVE-2024-51941/): Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts (high 8.8)
- [CVE-2025-23196](https://insights.sbomify.com/CVE-2025-23196/): Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4976 and fix it if it is affected.

What it is: CVE-2016-4976 is a medium-severity vulnerability in n/a, published on 29 Mar 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4976 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ambari:ambari (Maven): affected from 2.0.0; fixed in 2.4.0
- org.apache.ambari:ambari (Maven): affected from 2.0.0; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4976/ (Markdown: https://insights.sbomify.com/CVE-2016-4976/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4976
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4976
- OSV: https://osv.dev/vulnerability/CVE-2016-4976

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4976/
Summaries are generated and may contain mistakes; the official description above is the record.
