CVE-2016-4985 OpenStack Ironic Exposure of Sensitive Information to an Unauthorized Actor
Remote attackers can obtain sensitive node information by sending crafted requests using known MAC addresses in OpenStack Ironic.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-4985?
CVE-2016-4985 is a high-severity vulnerability in Redhat Openstack, published on 12 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The ironic-api service in OpenStack Ironic before 4.2.5 (Liberty) and 5.x before 5.1.2 (Mitaka) allows remote attackers to obtain sensitive information about a registered node by leveraging knowledge of the MAC address of a network card belonging to that node and sending a crafted POST request to the v1/drivers/$DRIVER_NAME/vendor_passthru resource.
Weakness: CWE-200
Which versions are affected by CVE-2016-4985?
5 open source packages ship an affected version, including ironic. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
ironic PyPI | All versions | 4.2.5, 5.1.2 |
ironic PyPI | All versions | 4.2.5 |
ironic PyPI | All versions | 4.2.5 |
ironic PyPI | From 5.0 | 5.1.2 |
ironic PyPI | From 5.0 | 5.1.2 |
Linux distribution packages (20)
openstack-ironic Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-4.el7ost |
openstack-ironic-api Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-4.el7ost |
openstack-ironic-common Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-4.el7ost |
openstack-ironic-conductor Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-4.el7ost |
openstack-ironic Red Hat:openstack:8::el7 | All versions | 1:4.2.5-1.el7ost |
openstack-ironic-api Red Hat:openstack:8::el7 | All versions | 1:4.2.5-1.el7ost |
openstack-ironic-common Red Hat:openstack:8::el7 | All versions | 1:4.2.5-1.el7ost |
openstack-ironic-conductor Red Hat:openstack:8::el7 | All versions | 1:4.2.5-1.el7ost |
openstack-designate SUSE:OpenStack Cloud 6 | All versions | 1.0.3~a0~dev10-6.1 |
openstack-designate-doc SUSE:OpenStack Cloud 6 | All versions | 1.0.3~a0~dev10-6.2 |
openstack-ironic SUSE:OpenStack Cloud 6 | All versions | 4.2.5-6.1 |
openstack-ironic-doc SUSE:OpenStack Cloud 6 | All versions | 4.2.5-6.2 |
openstack-neutron-vpnaas SUSE:OpenStack Cloud 6 | All versions | 7.0.5~a0~dev3-6.1 |
openstack-neutron-vpnaas-doc SUSE:OpenStack Cloud 6 | All versions | 7.0.5~a0~dev3-6.1 |
openstack-nova-docker SUSE:OpenStack Cloud 6 | All versions | 0.0.1~a0~dev238-4.1 |
openstack-sahara SUSE:OpenStack Cloud 6 | All versions | 3.0.3~a0~dev1-6.1 |
openstack-sahara-doc SUSE:OpenStack Cloud 6 | All versions | 3.0.3~a0~dev1-6.1 |
openstack-tempest SUSE:OpenStack Cloud 6 | All versions | 7.0.0-9.1 |
openstack-trove SUSE:OpenStack Cloud 6 | All versions | 4.0.1~a0~dev19-8.1 |
openstack-trove-doc SUSE:OpenStack Cloud 6 | All versions | 4.0.1~a0~dev19-8.1 |
Products include Canonical Openstack Ironic, Redhat Openstack.
How do I fix CVE-2016-4985?
Upgrade ironic to a fixed version for your release line: 4.2.5 or 5.1.2.
Is CVE-2016-4985 being exploited?
There is no known exploitation of CVE-2016-4985 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2016-4985, GHSA-f7cr-7c2c-fm8r, PYSEC-2026-646, RHSA-2016:1377, RHSA-2016:1378, SUSE-SU-2016:1966-1 and 1 more.