# CVE-2016-4985: OpenStack Ironic Exposure of Sensitive Information to an Unauthorized Actor

> Remote attackers can obtain sensitive node information by sending crafted requests using known MAC addresses in OpenStack Ironic.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-4985, GHSA-f7cr-7c2c-fm8r, PYSEC-2026-646, RHSA-2016:1377, RHSA-2016:1378, SUSE-SU-2016:1966-1, UBUNTU-CVE-2016-4985

## What is CVE-2016-4985?

CVE-2016-4985 is a high-severity vulnerability in Redhat Openstack, published on 12 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ironic-api service in OpenStack Ironic before 4.2.5 (Liberty) and 5.x before 5.1.2 (Mitaka) allows remote attackers to obtain sensitive information about a registered node by leveraging knowledge of the MAC address of a network card belonging to that node and sending a crafted POST request to the v1/drivers/$DRIVER_NAME/vendor_passthru resource.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-4985?

5 open source packages ship an affected version, including ironic. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ironic` | PyPI | All versions | 4.2.5, 5.1.2 |
| `ironic` | PyPI | All versions | 4.2.5 |
| `ironic` | PyPI | All versions | 4.2.5 |
| `ironic` | PyPI | From 5.0 | 5.1.2 |
| `ironic` | PyPI | From 5.0 | 5.1.2 |
| `openstack-ironic` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-4.el7ost |
| `openstack-ironic-api` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-4.el7ost |
| `openstack-ironic-common` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-4.el7ost |
| `openstack-ironic-conductor` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-4.el7ost |
| `openstack-ironic` | Red Hat:openstack:8::el7 | All versions | 1:4.2.5-1.el7ost |
| `openstack-ironic-api` | Red Hat:openstack:8::el7 | All versions | 1:4.2.5-1.el7ost |
| `openstack-ironic-common` | Red Hat:openstack:8::el7 | All versions | 1:4.2.5-1.el7ost |
| `openstack-ironic-conductor` | Red Hat:openstack:8::el7 | All versions | 1:4.2.5-1.el7ost |
| `openstack-designate` | SUSE:OpenStack Cloud 6 | All versions | 1.0.3~a0~dev10-6.1 |
| `openstack-designate-doc` | SUSE:OpenStack Cloud 6 | All versions | 1.0.3~a0~dev10-6.2 |
| `openstack-ironic` | SUSE:OpenStack Cloud 6 | All versions | 4.2.5-6.1 |
| `openstack-ironic-doc` | SUSE:OpenStack Cloud 6 | All versions | 4.2.5-6.2 |
| `openstack-neutron-vpnaas` | SUSE:OpenStack Cloud 6 | All versions | 7.0.5~a0~dev3-6.1 |
| `openstack-neutron-vpnaas-doc` | SUSE:OpenStack Cloud 6 | All versions | 7.0.5~a0~dev3-6.1 |
| `openstack-nova-docker` | SUSE:OpenStack Cloud 6 | All versions | 0.0.1~a0~dev238-4.1 |
| `openstack-sahara` | SUSE:OpenStack Cloud 6 | All versions | 3.0.3~a0~dev1-6.1 |
| `openstack-sahara-doc` | SUSE:OpenStack Cloud 6 | All versions | 3.0.3~a0~dev1-6.1 |
| `openstack-tempest` | SUSE:OpenStack Cloud 6 | All versions | 7.0.0-9.1 |
| `openstack-trove` | SUSE:OpenStack Cloud 6 | All versions | 4.0.1~a0~dev19-8.1 |
| `openstack-trove-doc` | SUSE:OpenStack Cloud 6 | All versions | 4.0.1~a0~dev19-8.1 |

Products: Canonical Openstack Ironic, Redhat Openstack.

## How do I fix CVE-2016-4985?

Upgrade ironic to a fixed version for your release line: 4.2.5 or 5.1.2.

## Is CVE-2016-4985 being exploited?

There is no known exploitation of CVE-2016-4985 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4985 and fix it if it is affected.

What it is: CVE-2016-4985 is a high-severity vulnerability in Redhat Openstack, published on 12 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4985 in the wild and no public exploit code.

Affected packages and fixed versions:
- ironic (PyPI): affected all versions; fixed in 4.2.5, 5.1.2
- ironic (PyPI): affected all versions; fixed in 4.2.5
- ironic (PyPI): affected all versions; fixed in 4.2.5
- ironic (PyPI): affected from 5.0; fixed in 5.1.2
- ironic (PyPI): affected from 5.0; fixed in 5.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4985/ (Markdown: https://insights.sbomify.com/CVE-2016-4985/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4985
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4985
- OSV: https://osv.dev/vulnerability/CVE-2016-4985

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4985/
Summaries are generated and may contain mistakes; the official description above is the record.
