# CVE-2016-4986: Jenkins TAP Plugin allows Path Traversal

> Remote attackers can read arbitrary files on the server via a directory traversal flaw in the Jenkins TAP plugin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-24jc-w55j-5p83

## What is CVE-2016-4986?

CVE-2016-4986 is a high-severity path traversal vulnerability in n/a, published on 9 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in the TAP plugin before 1.25 in Jenkins allows remote attackers to read arbitrary files via an unspecified parameter.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-4986?

2 open source packages ship an affected version, including org.tap4j:tap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.tap4j:tap` | Maven | All versions | 1.25 |
| `org.tap4j:tap` | Maven | All versions | 1.25 |

Products: Jenkins Tap.

## How do I fix CVE-2016-4986?

Upgrade org.tap4j:tap to 1.25 or later.

## Is CVE-2016-4986 being exploited?

There is no known exploitation of CVE-2016-4986 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-41940](https://insights.sbomify.com/CVE-2023-41940/): Stored XSS vulnerability in Jenkins TAP Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4986 and fix it if it is affected.

What it is: CVE-2016-4986 is a high-severity path traversal vulnerability in n/a, published on 9 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4986 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.tap4j:tap (Maven): affected all versions; fixed in 1.25
- org.tap4j:tap (Maven): affected all versions; fixed in 1.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4986/ (Markdown: https://insights.sbomify.com/CVE-2016-4986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4986
- OSV: https://osv.dev/vulnerability/CVE-2016-4986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4986/
Summaries are generated and may contain mistakes; the official description above is the record.
