# CVE-2016-4987: Jenkins Image Gallery Plugin allows Path Traversal

> Remote attackers can list arbitrary directories and read arbitrary files in the Jenkins Image Gallery plugin due to a directory traversal flaw.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8xr3-54w2-8xjp

## What is CVE-2016-4987?

CVE-2016-4987 is a medium-severity path traversal vulnerability in n/a, published on 9 Feb 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directory traversal vulnerability in the Image Gallery plugin before 1.4 in Jenkins allows remote attackers to list arbitrary directories and read arbitrary files via unspecified form fields.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-4987?

2 open source packages ship an affected version, including com.tupilabs.image_gallery:image-gallery. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.tupilabs.image_gallery:image-gallery` | Maven | All versions | 1.4 |
| `com.tupilabs.image_gallery:image-gallery` | Maven | All versions | 1.4 |

Products: Jenkins Image Gallery.

## How do I fix CVE-2016-4987?

Upgrade com.tupilabs.image_gallery:image-gallery to 1.4 or later.

## Is CVE-2016-4987 being exploited?

There is no known exploitation of CVE-2016-4987 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-4987 and fix it if it is affected.

What it is: CVE-2016-4987 is a medium-severity path traversal vulnerability in n/a, published on 9 Feb 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-4987 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.tupilabs.image_gallery:image-gallery (Maven): affected all versions; fixed in 1.4
- com.tupilabs.image_gallery:image-gallery (Maven): affected all versions; fixed in 1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-4987/ (Markdown: https://insights.sbomify.com/CVE-2016-4987/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-4987
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-4987
- OSV: https://osv.dev/vulnerability/CVE-2016-4987

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-4987/
Summaries are generated and may contain mistakes; the official description above is the record.
