CVE-2016-5001 Exposure of Sensitive Information to an Unauthorized Actor in Apache Hadoop

Medium 5.5 Published Updated

A local user on an HDFS DataNode can craft block tokens to gain unauthorized read access to random files in Apache Hadoop.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2016-5001?

CVE-2016-5001 is a medium-severity vulnerability in Apache Hadoop, published on 30 Aug 2017. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

This is an information disclosure vulnerability in Apache Hadoop before 2.6.4 and 2.7.x before 2.7.2 in the short-circuit reads feature of HDFS. A local user on an HDFS DataNode may be able to craft a block token that grants unauthorized read access to random files by guessing certain fields in the token.

Weakness: CWE-200

Which versions are affected by CVE-2016-5001?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.

PackageAffectedFixed in
org.apache.hadoop:hadoop-common MavenAll versions2.6.4
org.apache.hadoop:hadoop-common MavenAll versions2.6.4
org.apache.hadoop:hadoop-common MavenFrom 2.7.02.7.2
org.apache.hadoop:hadoop-common MavenFrom 2.7.02.7.2

Products include Apache Hadoop.

How do I fix CVE-2016-5001?

Upgrade org.apache.hadoop:hadoop-common to a fixed version for your release line: 2.6.4 or 2.7.2.

Is CVE-2016-5001 being exploited?

There is no known exploitation of CVE-2016-5001 in the wild and no public exploit code.

Sources

Also known as GHSA-8r28-r8cp-g6cp.

Is CVE-2016-5001 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free