{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.archiva:archiva. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-5005 in the wild and no public exploit code.","fix":"Upgrade org.apache.archiva:archiva to 2.2.1 or later.","what":"CVE-2016-5005 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Jul 2016. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-5005 and fix it if it is affected.\n\nWhat it is: CVE-2016-5005 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Jul 2016. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-5005 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.archiva:archiva (Maven): affected all versions; fixed in 2.2.1\n- org.apache.archiva:archiva (Maven): affected all versions; fixed in 2.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-5005/ (Markdown: https://insights.sbomify.com/CVE-2016-5005/index.md)","id":"CVE-2016-5005","markdown":"https://insights.sbomify.com/CVE-2016-5005/index.md","name":"CVE-2016-5005","record":{"aliases":["GHSA-8jfm-rgmg-3wq2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Archiva","requires_auth":"high_privilege","summary":"Remote authenticated administrators can inject arbitrary web script or HTML via the connector.sourceRepoId parameter in Apache Archiva.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"archiva","vendor":"apache"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in Apache Archiva 1.3.9 and earlier allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnector_commit.action.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Archiva vulnerable to Cross-site Scripting","id":"CVE-2016-5005","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2016"},"n_packages":2,"n_references":6,"next":{"headline":"Information disclosure in n/a","id":"CVE-2016-5006"},"packages":[{"ecosystem":"Maven","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.archiva:archiva","purl":null,"source":"GHSA-8jfm-rgmg-3wq2"},{"ecosystem":"Maven","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.archiva:archiva","purl":"pkg:maven/org.apache.archiva/archiva","source":"GHSA-8jfm-rgmg-3wq2"}],"prev":{"headline":"ws-xmlrpc DoS Vulnerability","id":"CVE-2016-5004"},"products":["n/a"],"published":"2016-07-28","related":[{"cvss_score":9.8,"headline":"Apache Struts Improper Input Validation","id":"CVE-2013-2251","kev_date_added":"2022-03-25","published":"2013-07-18"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2016-4469","kev_date_added":null,"published":"2016-07-28"},{"cvss_score":8,"headline":"Apache Archiva vulnerable to Cross Site Request Forgery","id":"CVE-2017-5657","kev_date_added":null,"published":"2017-05-22"},{"cvss_score":7.5,"headline":"Apache Archiva: disabling user registration is not effective","id":"CVE-2024-27138","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":7.5,"headline":"Apache Archiva: incorrect authentication potentially leading to account takeover","id":"CVE-2024-27139","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":7.5,"headline":"Apache Archiva prior to 2.2.9 may allow the anonymous user to read arbitrary files","id":"CVE-2022-40308","kev_date_added":null,"published":"2022-11-15"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2011-1026","kev_date_added":null,"published":"2011-06-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote authenticated administrators can inject arbitrary web script or HTML via the connector.sourceRepoId parameter in Apache Archiva.","url":"https://insights.sbomify.com/CVE-2016-5005/"}