CVE-2016-5016 Cloud Foundry vulnerable to Improper Certificate Validation
The User Account and Authentication Server fails to validate expired certificates, allowing attackers to bypass security controls using invalid credentials.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-5016?
CVE-2016-5016 is a medium-severity vulnerability in n/a, published on 24 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Pivotal Cloud Foundry 239 and earlier, UAA (aka User Account and Authentication Server) 3.4.1 and earlier, UAA release 12.2 and earlier, PCF (aka Pivotal Cloud Foundry) Elastic Runtime 1.6.x before 1.6.35, and PCF Elastic Runtime 1.7.x before 1.7.13 does not validate if a certificate is expired.
Weakness: CWE-295
Which versions are affected by CVE-2016-5016?
4 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.0.0 | 3.3.0.3 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.0.0 | 3.3.0.3 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.4.0 | 3.4.2 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.4.0 | 3.4.2 |
Products include Pivotal Software Cloud Foundry, Pivotal Software Cloud Foundry Elastic Runtime, Pivotal Software Cloud Foundry Uaa, Pivotal Software Cloud Foundry Uaa-Release.
How do I fix CVE-2016-5016?
Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.3.0.3 or 3.4.2.
Is CVE-2016-5016 being exploited?
There is no known exploitation of CVE-2016-5016 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-rc2r-w8jv-vggp.