{"answers":{"affected":"4 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 4 products.","exploited":"There is no known exploitation of CVE-2016-5016 in the wild and no public exploit code.","fix":"Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.3.0.3 or 3.4.2.","what":"CVE-2016-5016 is a medium-severity vulnerability in n/a, published on 24 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-5016 and fix it if it is affected.\n\nWhat it is: CVE-2016-5016 is a medium-severity vulnerability in n/a, published on 24 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-5016 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.3.0.3\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.3.0.3\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.4.0; fixed in 3.4.2\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.4.0; fixed in 3.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-5016/ (Markdown: https://insights.sbomify.com/CVE-2016-5016/index.md)","id":"CVE-2016-5016","markdown":"https://insights.sbomify.com/CVE-2016-5016/index.md","name":"CVE-2016-5016","record":{"aliases":["GHSA-rc2r-w8jv-vggp"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloud Foundry UAA","requires_auth":"none","summary":"The User Account and Authentication Server fails to validate expired certificates, allowing attackers to bypass security controls using invalid credentials.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cloud_foundry","vendor":"pivotal_software"},{"product":"cloud_foundry_elastic_runtime","vendor":"pivotal_software"},{"product":"cloud_foundry_uaa","vendor":"pivotal_software"},{"product":"cloud_foundry_uaa-release","vendor":"pivotal_software"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Pivotal Cloud Foundry 239 and earlier, UAA (aka User Account and Authentication Server) 3.4.1 and earlier, UAA release 12.2 and earlier, PCF (aka Pivotal Cloud Foundry) Elastic Runtime 1.6.x before 1.6.35, and PCF Elastic Runtime 1.7.x before 1.7.13 does not validate if a certificate is expired.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cloud Foundry vulnerable to Improper Certificate Validation","id":"CVE-2016-5016","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2016"},"n_packages":4,"n_references":7,"next":{"headline":"Memory corruption in n/a","id":"CVE-2016-5017"},"packages":[{"ecosystem":"Maven","fixed":["3.3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-rc2r-w8jv-vggp"},{"ecosystem":"Maven","fixed":["3.3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-rc2r-w8jv-vggp"},{"ecosystem":"Maven","fixed":["3.4.2"],"introduced":["3.4.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-rc2r-w8jv-vggp"},{"ecosystem":"Maven","fixed":["3.4.2"],"introduced":["3.4.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-rc2r-w8jv-vggp"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2016-5015"},"products":["n/a"],"published":"2017-04-24","related":[{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2016-5006","kev_date_added":null,"published":"2017-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"The User Account and Authentication Server fails to validate expired certificates, allowing attackers to bypass security controls using invalid credentials.","url":"https://insights.sbomify.com/CVE-2016-5016/"}