# CVE-2016-5016: Cloud Foundry vulnerable to Improper Certificate Validation

> The User Account and Authentication Server fails to validate expired certificates, allowing attackers to bypass security controls using invalid credentials.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-rc2r-w8jv-vggp

## What is CVE-2016-5016?

CVE-2016-5016 is a medium-severity vulnerability in n/a, published on 24 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pivotal Cloud Foundry 239 and earlier, UAA (aka User Account and Authentication Server) 3.4.1 and earlier, UAA release 12.2 and earlier, PCF (aka Pivotal Cloud Foundry) Elastic Runtime 1.6.x before 1.6.35, and PCF Elastic Runtime 1.7.x before 1.7.13 does not validate if a certificate is expired.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2016-5016?

4 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.3.0.3 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.3.0.3 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.4.0 | 3.4.2 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.4.0 | 3.4.2 |

Products: Pivotal Software Cloud Foundry, Pivotal Software Cloud Foundry Elastic Runtime, Pivotal Software Cloud Foundry Uaa, Pivotal Software Cloud Foundry Uaa-Release.

## How do I fix CVE-2016-5016?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.3.0.3 or 3.4.2.

## Is CVE-2016-5016 being exploited?

There is no known exploitation of CVE-2016-5016 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-5006](https://insights.sbomify.com/CVE-2016-5006/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5016 and fix it if it is affected.

What it is: CVE-2016-5016 is a medium-severity vulnerability in n/a, published on 24 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5016 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.3.0.3
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.3.0.3
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.4.0; fixed in 3.4.2
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.4.0; fixed in 3.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5016/ (Markdown: https://insights.sbomify.com/CVE-2016-5016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5016
- OSV: https://osv.dev/vulnerability/CVE-2016-5016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5016/
Summaries are generated and may contain mistakes; the official description above is the record.
