CVE-2016-5091 Extbase for TYPO3 allows RCE

High 8.1 Published Updated

Remote attackers can execute arbitrary code or read sensitive data in TYPO3 via crafted Extbase actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-5091?

CVE-2016-5091 is a high-severity code injection vulnerability in Typo3 Typo3, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Extbase in TYPO3 4.3.0 before 6.2.24, 7.x before 7.6.8, and 8.1.1 allows remote attackers to obtain sensitive information or possibly execute arbitrary code via a crafted Extbase action.

Weakness: CWE-254

Which versions are affected by CVE-2016-5091?

6 open source packages ship an affected version, including typo3/cms-extbase. It affects 1 product.

PackageAffectedFixed in
typo3/cms-extbase PackagistAll versionsNone
typo3/cms-extbase PackagistAll versionsNone
typo3/cms-extbase PackagistAll versions6.2.24
typo3/cms-extbase PackagistAll versions6.2.24
typo3/cms-extbase PackagistFrom 7.07.6.8
typo3/cms-extbase PackagistFrom 7.07.6.8

Products include Typo3 Typo3.

How do I fix CVE-2016-5091?

Upgrade typo3/cms-extbase to a fixed version for your release line: 6.2.24 or 7.6.8.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2016-5091 being exploited?

There is no known exploitation of CVE-2016-5091 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-jxg5-35fj-ccwf.

Is CVE-2016-5091 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free