# CVE-2016-5100: Froxlor guessable password reset token

> Remote attackers can predict password reset tokens due to weak random number generation, potentially leading to account takeover.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qj6h-m7xc-r2v3, openSUSE-SU-2021:0415-1, openSUSE-SU-2021:0450-1

## What is CVE-2016-5100?

CVE-2016-5100 is a critical vulnerability in n/a, published on 13 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Froxlor before 0.9.35 uses the PHP rand function for random number generation, which makes it easier for remote attackers to guess the password reset token by predicting a value.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2016-5100?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 0.9.35 |
| `froxlor/froxlor` | Packagist | All versions | 0.9.35 |
| `froxlor` | SUSE:Package Hub 15 SP2 | All versions | 0.10.23-bp152.4.3.1 |
| `froxlor` | openSUSE:Leap 15.2 | All versions | 0.10.23-lp152.4.3.1 |

Products: Froxlor Froxlor.

## How do I fix CVE-2016-5100?

Upgrade froxlor/froxlor to 0.9.35 or later.

## Is CVE-2016-5100 being exploited?

There is no known exploitation of CVE-2016-5100 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-41228](https://insights.sbomify.com/CVE-2026-41228/): Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution (critical 10.0)
- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5100 and fix it if it is affected.

What it is: CVE-2016-5100 is a critical vulnerability in n/a, published on 13 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5100 in the wild and no public exploit code.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 0.9.35
- froxlor/froxlor (Packagist): affected all versions; fixed in 0.9.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5100/ (Markdown: https://insights.sbomify.com/CVE-2016-5100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5100
- OSV: https://osv.dev/vulnerability/CVE-2016-5100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5100/
Summaries are generated and may contain mistakes; the official description above is the record.
