CVE-2016-5388 Improper Access Control in Apache Tomcat
Attackers can redirect outbound HTTP traffic to arbitrary proxies via crafted headers when the CGI Servlet is enabled, potentially exposing internal data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-5388?
CVE-2016-5388 is a high-severity server-side request forgery vulnerability in Apache Tomcat, published on 19 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Tomcat 7.x through 7.0.70 and 8.x through 8.5.4, when the CGI Servlet is enabled, follows RFC 3875 section 4.1.18 and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue. NOTE: the vendor states "A mitigation is planned for future releases of Tomcat, tracked as CVE-2016-5388"; in other words, this is not a CVE ID for a vulnerability.
Weakness: CWE-284
Which versions are affected by CVE-2016-5388?
4 open source packages ship an affected version, including org.apache.tomcat:tomcat-catalina. It affects 11 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat-catalina Maven | From 7.0.0 | 7.0.72 |
org.apache.tomcat:tomcat-catalina Maven | From 7.0.0 | 7.0.72 |
org.apache.tomcat:tomcat-catalina Maven | From 8.0.0 | 8.5.5 |
org.apache.tomcat:tomcat-catalina Maven | From 8.0.0 | 8.5.5 |
Linux distribution packages (2)
tomcat6 SUSE:Linux Enterprise Server 11 SP4 | All versions | 6.0.45-0.53.2 |
tomcat6 SUSE:Linux Enterprise Server for SAP Applications 11 SP4 | All versions | 6.0.45-0.53.2 |
Products include Apache Tomcat, Hp System Management Homepage, Oracle Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Hpc Node, Redhat Enterprise Linux Hpc Node Eus and 5 more.
How do I fix CVE-2016-5388?
Upgrade org.apache.tomcat:tomcat-catalina to a fixed version for your release line: 7.0.72 or 8.5.5.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2016-5388 being exploited?
There is no known exploitation of CVE-2016-5388 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as CVE-2016-1000106, GHSA-v646-rx6w-r3qq, MGASA-2016-0312, SUSE-SU-2016:2229-1, UBUNTU-CVE-2016-5388.