# CVE-2016-5388: Improper Access Control in Apache Tomcat

> Attackers can redirect outbound HTTP traffic to arbitrary proxies via crafted headers when the CGI Servlet is enabled, potentially exposing internal data.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jul 2016
- **Updated:** 15 Oct 2026
- **Also known as:** CVE-2016-1000106, GHSA-v646-rx6w-r3qq, MGASA-2016-0312, SUSE-SU-2016:2229-1, UBUNTU-CVE-2016-5388

## What is CVE-2016-5388?

CVE-2016-5388 is a high-severity server-side request forgery vulnerability in Apache Tomcat, published on 19 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Tomcat 7.x through 7.0.70 and 8.x through 8.5.4, when the CGI Servlet is enabled, follows RFC 3875 section 4.1.18 and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue. NOTE: the vendor states "A mitigation is planned for future releases of Tomcat, tracked as CVE-2016-5388"; in other words, this is not a CVE ID for a vulnerability.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-5388?

4 open source packages ship an affected version, including org.apache.tomcat:tomcat-catalina. It affects 11 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 7.0.0 | 7.0.72 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 7.0.0 | 7.0.72 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.0.0 | 8.5.5 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.0.0 | 8.5.5 |
| `tomcat6` | SUSE:Linux Enterprise Server 11 SP4 | All versions | 6.0.45-0.53.2 |
| `tomcat6` | SUSE:Linux Enterprise Server for SAP Applications 11 SP4 | All versions | 6.0.45-0.53.2 |

Products: Apache Tomcat, Hp System Management Homepage, Oracle Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Hpc Node, Redhat Enterprise Linux Hpc Node Eus, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus, Redhat Enterprise Linux Server Tus, Redhat Enterprise Linux Workstation.

## How do I fix CVE-2016-5388?

Upgrade org.apache.tomcat:tomcat-catalina to a fixed version for your release line: 7.0.72 or 8.5.5.

## Is CVE-2016-5388 being exploited?

There is no known exploitation of CVE-2016-5388 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5388 and fix it if it is affected.

What it is: CVE-2016-5388 is a high-severity server-side request forgery vulnerability in Apache Tomcat, published on 19 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5388 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat-catalina (Maven): affected from 7.0.0; fixed in 7.0.72
- org.apache.tomcat:tomcat-catalina (Maven): affected from 7.0.0; fixed in 7.0.72
- org.apache.tomcat:tomcat-catalina (Maven): affected from 8.0.0; fixed in 8.5.5
- org.apache.tomcat:tomcat-catalina (Maven): affected from 8.0.0; fixed in 8.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5388/ (Markdown: https://insights.sbomify.com/CVE-2016-5388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5388
- OSV: https://osv.dev/vulnerability/CVE-2016-5388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5388/
Summaries are generated and may contain mistakes; the official description above is the record.
