CVE-2016-5393 Improper Access Control in Apache Hadoop

High 8.8 Published Updated

Authenticated remote users can execute arbitrary commands with HDFS service privileges in Apache Hadoop.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-5393?

CVE-2016-5393 is a high-severity command injection vulnerability in Apache Hadoop, published on 29 Nov 2016. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Apache Hadoop 2.6.x before 2.6.5 and 2.7.x before 2.7.3, a remote user who can authenticate with the HDFS NameNode can possibly run arbitrary commands with the same privileges as the HDFS service.

Weakness: CWE-284

Which versions are affected by CVE-2016-5393?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.

PackageAffectedFixed in
org.apache.hadoop:hadoop-common MavenFrom 2.6.02.6.5
org.apache.hadoop:hadoop-common MavenFrom 2.6.02.6.5
org.apache.hadoop:hadoop-common MavenFrom 2.7.02.7.3
org.apache.hadoop:hadoop-common MavenFrom 2.7.02.7.3

Products include Apache Hadoop.

How do I fix CVE-2016-5393?

Upgrade org.apache.hadoop:hadoop-common to a fixed version for your release line: 2.6.5 or 2.7.3.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2016-5393 being exploited?

There is no known exploitation of CVE-2016-5393 in the wild and no public exploit code.

Sources

Also known as GHSA-7q56-mp4c-gggg.

Is CVE-2016-5393 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free