# CVE-2016-5393: Improper Access Control in Apache Hadoop

> Authenticated remote users can execute arbitrary commands with HDFS service privileges in Apache Hadoop.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7q56-mp4c-gggg

## What is CVE-2016-5393?

CVE-2016-5393 is a high-severity command injection vulnerability in Apache Hadoop, published on 29 Nov 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Hadoop 2.6.x before 2.6.5 and 2.7.x before 2.7.3, a remote user who can authenticate with the HDFS NameNode can possibly run arbitrary commands with the same privileges as the HDFS service.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-5393?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.6.0 | 2.6.5 |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.6.0 | 2.6.5 |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.7.0 | 2.7.3 |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.7.0 | 2.7.3 |

Products: Apache Hadoop.

## How do I fix CVE-2016-5393?

Upgrade org.apache.hadoop:hadoop-common to a fixed version for your release line: 2.6.5 or 2.7.3.

## Is CVE-2016-5393 being exploited?

There is no known exploitation of CVE-2016-5393 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hadoop

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5393 and fix it if it is affected.

What it is: CVE-2016-5393 is a high-severity command injection vulnerability in Apache Hadoop, published on 29 Nov 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5393 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-common (Maven): affected from 2.6.0; fixed in 2.6.5
- org.apache.hadoop:hadoop-common (Maven): affected from 2.6.0; fixed in 2.6.5
- org.apache.hadoop:hadoop-common (Maven): affected from 2.7.0; fixed in 2.7.3
- org.apache.hadoop:hadoop-common (Maven): affected from 2.7.0; fixed in 2.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5393/ (Markdown: https://insights.sbomify.com/CVE-2016-5393/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5393
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5393
- OSV: https://osv.dev/vulnerability/CVE-2016-5393

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5393/
Summaries are generated and may contain mistakes; the official description above is the record.
