# CVE-2016-5394: Cross site scripting in Apache Sling

> Insufficient encoding in Apache Sling XSS API allows script tags to bypass filters, enabling cross-site scripting attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jul 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-xwf4-88xr-hx2j

## What is CVE-2016-5394?

CVE-2016-5394 is a medium-severity cross-site scripting vulnerability in Apache Sling, published on 19 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In the XSS Protection API module before 1.0.12 in Apache Sling, the encoding done by the XSSAPI.encodeForJSString() method is not restrictive enough and for some input patterns allows script tags to pass through unencoded, leading to potential XSS vulnerabilities.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-5394?

4 open source packages ship an affected version, including org.apache.sling:org.apache.sling.xss and org.apache.sling:org.apache.sling.xss.compat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.xss` | Maven | All versions | 1.0.12 |
| `org.apache.sling:org.apache.sling.xss` | Maven | All versions | 1.0.12 |
| `org.apache.sling:org.apache.sling.xss.compat` | Maven | All versions | 1.1.0 |
| `org.apache.sling:org.apache.sling.xss.compat` | Maven | All versions | 1.1.0 |

Products: Apache Sling.

## How do I fix CVE-2016-5394?

Upgrade org.apache.sling:org.apache.sling.xss to 1.0.12 or later.

## Is CVE-2016-5394 being exploited?

There is no known exploitation of CVE-2016-5394 in the wild and no public exploit code.

Public exploit code:

- apache/sling with CVE-2016-5394 (github_poc): https://github.com/epicosy/VUL4J-23
- https://github.com/shoucheng3/apache__sling-org-apache-sling-xss_CVE-2016-5394_1-0-8 (github_poc): https://github.com/shoucheng3/apache__sling-org-apache-sling-xss_CVE-2016-5394_1-0-8

## Other vulnerabilities in Apache Sling

- [CVE-2016-6798](https://insights.sbomify.com/CVE-2016-6798/): XML External Entity Reference in Apache Sling (critical 9.8)
- [CVE-2013-4390](https://insights.sbomify.com/CVE-2013-4390/): Apache Sling Auth Core bundle vulnerable to Open Redirection (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5394 and fix it if it is affected.

What it is: CVE-2016-5394 is a medium-severity cross-site scripting vulnerability in Apache Sling, published on 19 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-5394 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.xss (Maven): affected all versions; fixed in 1.0.12
- org.apache.sling:org.apache.sling.xss (Maven): affected all versions; fixed in 1.0.12
- org.apache.sling:org.apache.sling.xss.compat (Maven): affected all versions; fixed in 1.1.0
- org.apache.sling:org.apache.sling.xss.compat (Maven): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5394/ (Markdown: https://insights.sbomify.com/CVE-2016-5394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5394
- OSV: https://osv.dev/vulnerability/CVE-2016-5394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5394/
Summaries are generated and may contain mistakes; the official description above is the record.
