# CVE-2016-5395: Apache Ranger allows remote authenticated administrators to inject arbitrary web script or HTML

> Remote authenticated administrators can inject arbitrary web script or HTML via the policy admin tool, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-rf7q-xqm3-6923

## What is CVE-2016-5395?

CVE-2016-5395 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Sep 2016. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool in Apache Ranger before 0.6.1 allows remote authenticated administrators to inject arbitrary web script or HTML via vectors related to policies.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-5395?

2 open source packages ship an affected version, including org.apache.ranger:ranger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ranger:ranger` | Maven | All versions | 0.6.1 |
| `org.apache.ranger:ranger` | Maven | All versions | 0.6.1 |

Products: Apache Ranger.

## How do I fix CVE-2016-5395?

Upgrade org.apache.ranger:ranger to 0.6.1 or later.

## Is CVE-2016-5395 being exploited?

There is no known exploitation of CVE-2016-5395 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-28672](https://insights.sbomify.com/CVE-2026-28672/): Apache Ranger: OS Command Injection via Username in UnixUserGroupBuilder (critical 9.8)
- [CVE-2026-32227](https://insights.sbomify.com/CVE-2026-32227/): Apache Ranger: SQL Injection vulnerability in lookup functionality (critical 9.8)
- [CVE-2026-40920](https://insights.sbomify.com/CVE-2026-40920/): Apache Ranger: Privilege Escalation via URL Parameter (critical 9.8)
- [CVE-2026-42537](https://insights.sbomify.com/CVE-2026-42537/): Apache Ranger: Remote Code Execution via JDBC URL Injection (critical 9.8)
- [CVE-2026-44416](https://insights.sbomify.com/CVE-2026-44416/): Apache Ranger: Remote Code Execution via Arbitrary Class Instantiation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5395 and fix it if it is affected.

What it is: CVE-2016-5395 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Sep 2016. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-5395 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ranger:ranger (Maven): affected all versions; fixed in 0.6.1
- org.apache.ranger:ranger (Maven): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5395/ (Markdown: https://insights.sbomify.com/CVE-2016-5395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5395
- OSV: https://osv.dev/vulnerability/CVE-2016-5395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5395/
Summaries are generated and may contain mistakes; the official description above is the record.
