CVE-2016-5397 Apache Thrift Go Library Command Injection

High 8.8 Published Updated

Command injection in Apache Thrift Go client code generation allows attackers to execute arbitrary commands via external formatting tools.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-5397?

CVE-2016-5397 is a high-severity command injection vulnerability in Apache Thrift, published on 12 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The Apache Thrift Go client library exposed the potential during code generation for command injection due to using an external formatting tool. Affected Apache Thrift 0.9.3 and older, Fixed in Apache Thrift 0.10.0.

Weakness: CWE-77

Which versions are affected by CVE-2016-5397?

2 open source packages ship an affected version, including github.com/apache/thrift. It affects 1 product.

PackageAffectedFixed in
github.com/apache/thrift GoAll versions0.10.0
github.com/apache/thrift GoAll versions0.10.0

Products include Apache Thrift.

How do I fix CVE-2016-5397?

Upgrade github.com/apache/thrift to 0.10.0 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2016-5397 being exploited?

There is no known exploitation of CVE-2016-5397 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2016-5397, GHSA-r4m4-pmvw-m6j5, UBUNTU-CVE-2016-5397.

Is CVE-2016-5397 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free