# CVE-2016-5397: Apache Thrift Go Library Command Injection

> Command injection in Apache Thrift Go client code generation allows attackers to execute arbitrary commands via external formatting tools.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2016-5397, GHSA-r4m4-pmvw-m6j5, UBUNTU-CVE-2016-5397

## What is CVE-2016-5397?

CVE-2016-5397 is a high-severity command injection vulnerability in Apache Thrift, published on 12 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Apache Thrift Go client library exposed the potential during code generation for command injection due to using an external formatting tool. Affected Apache Thrift 0.9.3 and older, Fixed in Apache Thrift 0.10.0.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2016-5397?

2 open source packages ship an affected version, including github.com/apache/thrift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/thrift` | Go | All versions | 0.10.0 |
| `github.com/apache/thrift` | Go | All versions | 0.10.0 |

Products: Apache Thrift.

## How do I fix CVE-2016-5397?

Upgrade github.com/apache/thrift to 0.10.0 or later.

## Is CVE-2016-5397 being exploited?

There is no known exploitation of CVE-2016-5397 in the wild and no public exploit code.

## Other vulnerabilities in Apache Thrift

- [CVE-2026-55971](https://insights.sbomify.com/CVE-2026-55971/): Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform() (critical 9.3)
- [CVE-2026-48144](https://insights.sbomify.com/CVE-2026-48144/): Apache Thrift: c_glib TLS Client Missing Hostname Verification (critical 9.1)
- [CVE-2026-43871](https://insights.sbomify.com/CVE-2026-43871/): Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit (high 8.7)
- [CVE-2026-48586](https://insights.sbomify.com/CVE-2026-48586/): Denial of service in Apache Thrift (high 8.7)
- [CVE-2026-55968](https://insights.sbomify.com/CVE-2026-55968/): Apache Thrift: Node.js quadratic-time DoS in server receive transports (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5397 and fix it if it is affected.

What it is: CVE-2016-5397 is a high-severity command injection vulnerability in Apache Thrift, published on 12 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5397 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/thrift (Go): affected all versions; fixed in 0.10.0
- github.com/apache/thrift (Go): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5397/ (Markdown: https://insights.sbomify.com/CVE-2016-5397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5397
- OSV: https://osv.dev/vulnerability/CVE-2016-5397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5397/
Summaries are generated and may contain mistakes; the official description above is the record.
