{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-5407 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-5407 is a critical memory corruption vulnerability in Fedoraproject Fedora, published on 13 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-5407 and fix it if it is affected.\n\nWhat it is: CVE-2016-5407 is a critical memory corruption vulnerability in Fedoraproject Fedora, published on 13 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-5407 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-5407/ (Markdown: https://insights.sbomify.com/CVE-2016-5407/index.md)","id":"CVE-2016-5407","markdown":"https://insights.sbomify.com/CVE-2016-5407/index.md","name":"CVE-2016-5407","record":{"aliases":["ALPINE-CVE-2016-5407","DEBIAN-CVE-2016-5407","DLA-667-1","GHSA-cwhm-4g62-g8f6","SUSE-SU-2016:3110-1","UBUNTU-CVE-2016-5407","USN-5449-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"X.org libXv library","requires_auth":"none","summary":"Remote X servers can trigger out-of-bounds memory access in libXv via crafted length specifications, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"libxv","vendor":"x.org"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"The (1) XvQueryAdaptors and (2) XvQueryEncodings functions in X.org libXv before 1.0.11 allow remote X servers to trigger out-of-bounds memory access operations via vectors involving length specifications in received data.","ecosystems":["SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 11 SP4","SUSE:Linux Enterprise Software Development Kit 11 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2016-5407","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"memory_corruption","year":"2016"},"n_packages":3,"n_references":9,"next":{"headline":"Memory corruption in n/a","id":"CVE-2016-5408"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["7.4-1.20.1"],"introduced":["0"],"last_affected":[],"package":"xorg-x11-libXv","purl":"pkg:rpm/suse/xorg-x11-libXv\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2016:3110-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["7.4-1.20.1"],"introduced":["0"],"last_affected":[],"package":"xorg-x11-libXv","purl":"pkg:rpm/suse/xorg-x11-libXv\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2016:3110-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["7.4-1.20.1"],"introduced":["0"],"last_affected":[],"package":"xorg-x11-libXv","purl":"pkg:rpm/suse/xorg-x11-libXv\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2016:3110-1"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2016-5406"},"products":["n/a"],"published":"2016-12-13","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote X servers can trigger out-of-bounds memory access in libXv via crafted length specifications, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2016-5407/"}