# CVE-2016-5431: PHP JOSE Library by Gree Inc. Uses a Broken or Risky Cryptographic Algorithm

> Attackers can bypass JWS signature verification in the PHP JOSE library by exploiting key confusion, allowing them to forge valid tokens.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-xm5f-hc9r-76f3

## What is CVE-2016-5431?

CVE-2016-5431 is a high-severity vulnerability in jose-php, published on 7 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The PHP JOSE Library by Gree Inc. before version 2.2.1 is vulnerable to key confusion/algorithm substitution in the JWS component resulting in bypassing the signature verification via crafted tokens.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2016-5431?

2 open source packages ship an affected version, including gree/jose. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gree/jose` | Packagist | All versions | 2.2.1 |
| `gree/jose` | Packagist | All versions | 2.2.1 |

Products: Php Jose Project Php Jose.

## How do I fix CVE-2016-5431?

Upgrade gree/jose to 2.2.1 or later.

## Is CVE-2016-5431 being exploited?

There is no known exploitation of CVE-2016-5431 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5431 and fix it if it is affected.

What it is: CVE-2016-5431 is a high-severity vulnerability in jose-php, published on 7 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5431 in the wild and no public exploit code.

Affected packages and fixed versions:
- gree/jose (Packagist): affected all versions; fixed in 2.2.1
- gree/jose (Packagist): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5431/ (Markdown: https://insights.sbomify.com/CVE-2016-5431/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5431
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5431
- OSV: https://osv.dev/vulnerability/CVE-2016-5431

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5431/
Summaries are generated and may contain mistakes; the official description above is the record.
