{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-5598 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-5598 is a medium-severity vulnerability in n/a, published on 25 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-5598 and fix it if it is affected.\n\nWhat it is: CVE-2016-5598 is a medium-severity vulnerability in n/a, published on 25 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-5598 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-5598/ (Markdown: https://insights.sbomify.com/CVE-2016-5598/index.md)","id":"CVE-2016-5598","markdown":"https://insights.sbomify.com/CVE-2016-5598/index.md","name":"CVE-2016-5598","record":{"aliases":["GHSA-j5cf-mr37-wmwc","UBUNTU-CVE-2016-5598","openSUSE-SU-2024:10543-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MySQL Connector/Python","requires_auth":"none","summary":"Remote attackers can compromise confidentiality, integrity, and availability of applications using the MySQL Connector/Python library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"oracle","cpe":[{"product":"mysql_connector\\/python","vendor":"oracle"}],"cvss":{"score":5.6,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Unspecified vulnerability in the MySQL Connector component 2.1.3 and earlier and 2.0.4 and earlier in Oracle MySQL allows remote attackers to affect confidentiality, integrity, and availability via vectors related to Connector/Python.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Other in n/a","id":"CVE-2016-5598","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2016"},"n_packages":1,"n_references":3,"next":{"headline":"Missing authorization in n/a","id":"CVE-2016-5599"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.1.4-1.1"],"introduced":["0"],"last_affected":[],"package":"python-mysql-connector-python","purl":"pkg:rpm/opensuse/python-mysql-connector-python\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10543-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-5597"},"products":["n/a"],"published":"2016-10-25","related":[{"cvss_score":7.5,"headline":"Denial of service in MySQL Connectors","id":"CVE-2024-21090","kev_date_added":null,"published":"2024-04-16"},{"cvss_score":6.4,"headline":"Denial of service in MySQL Connectors","id":"CVE-2025-21548","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":6.3,"headline":"Other in MySQL Connectors","id":"CVE-2024-21170","kev_date_added":null,"published":"2024-07-16"},{"cvss_score":4.8,"headline":"Information disclosure in MySQL Connectors","id":"CVE-2025-30714","kev_date_added":null,"published":"2025-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-10","vendors":["n/a"]},"summary":"Remote attackers can compromise confidentiality, integrity, and availability of applications using the MySQL Connector/Python library.","url":"https://insights.sbomify.com/CVE-2016-5598/"}