# CVE-2016-5682: Cross-Site Scripting in swagger-ui

> An attacker can execute arbitrary scripts in the victim's browser via the Default field in the Definitions section of Swagger-UI.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p239-93f7-h6xf

## What is CVE-2016-5682?

CVE-2016-5682 is a medium-severity cross-site scripting vulnerability in Swagger-UI before 2.2.1, published on 10 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Swagger-UI before 2.2.1 has XSS via the Default field in the Definitions section.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-5682?

2 open source packages ship an affected version, including swagger-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swagger-ui` | npm | All versions | 2.2.1 |
| `swagger-ui` | npm | All versions | 2.2.1 |

Products: Smartbear Swagger-Ui.

## How do I fix CVE-2016-5682?

Upgrade swagger-ui to 2.2.1 or later.

## Is CVE-2016-5682 being exploited?

There is no known exploitation of CVE-2016-5682 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5682 and fix it if it is affected.

What it is: CVE-2016-5682 is a medium-severity cross-site scripting vulnerability in Swagger-UI before 2.2.1, published on 10 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-5682 in the wild and no public exploit code.

Affected packages and fixed versions:
- swagger-ui (npm): affected all versions; fixed in 2.2.1
- swagger-ui (npm): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5682/ (Markdown: https://insights.sbomify.com/CVE-2016-5682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5682
- OSV: https://osv.dev/vulnerability/CVE-2016-5682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5682/
Summaries are generated and may contain mistakes; the official description above is the record.
