{"answers":{"affected":"2 open source packages ship an affected version, including ruby-saml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-5697 in the wild and no public exploit code.","fix":"Upgrade ruby-saml to 1.3.0 or later.","what":"CVE-2016-5697 is a high-severity vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-5697 and fix it if it is affected.\n\nWhat it is: CVE-2016-5697 is a high-severity vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-5697 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby-saml (RubyGems): affected all versions; fixed in 1.3.0\n- ruby-saml (RubyGems): affected all versions; fixed in 1.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-5697/ (Markdown: https://insights.sbomify.com/CVE-2016-5697/index.md)","id":"CVE-2016-5697","markdown":"https://insights.sbomify.com/CVE-2016-5697/index.md","name":"CVE-2016-5697","record":{"aliases":["DEBIAN-CVE-2016-5697","GHSA-36p7-xjw8-h6f2","UBUNTU-CVE-2016-5697"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SAML library","requires_auth":"none","summary":"Attackers can bypass SAML authentication via XML signature wrapping in the Ruby-saml library, potentially leading to unauthorized access or code execution.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ruby-saml","vendor":"onelogin"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-91","name":"XML Injection"}],"description":"Ruby-saml before 1.3.0 allows attackers to perform XML signature wrapping attacks via unspecified vectors.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ruby-saml allows attackers to perform XML signature wrapping attacks","id":"CVE-2016-5697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xxe","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Other in n/a","id":"CVE-2016-5699"},"packages":[{"ecosystem":"RubyGems","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":null,"source":"GHSA-36p7-xjw8-h6f2"},{"ecosystem":"RubyGems","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"ruby-saml","purl":"pkg:gem/ruby-saml","source":"GHSA-36p7-xjw8-h6f2"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-5696"},"products":["n/a"],"published":"2017-01-23","related":[{"cvss_score":9.8,"headline":"ruby-saml vulnerable to XPath injection","id":"CVE-2015-20108","kev_date_added":null,"published":"2023-05-27"},{"cvss_score":9.3,"headline":"ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)","id":"CVE-2025-66567","kev_date_added":null,"published":"2025-12-09"},{"cvss_score":9.3,"headline":"ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation","id":"CVE-2025-66568","kev_date_added":null,"published":"2025-12-09"},{"cvss_score":7.7,"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11428","kev_date_added":null,"published":"2019-04-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can bypass SAML authentication via XML signature wrapping in the Ruby-saml library, potentially leading to unauthorized access or code execution.","url":"https://insights.sbomify.com/CVE-2016-5697/"}