# CVE-2016-5697: Ruby-saml allows attackers to perform XML signature wrapping attacks

> Attackers can bypass SAML authentication via XML signature wrapping in the Ruby-saml library, potentially leading to unauthorized access or code execution.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-5697, GHSA-36p7-xjw8-h6f2, UBUNTU-CVE-2016-5697

## What is CVE-2016-5697?

CVE-2016-5697 is a high-severity vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ruby-saml before 1.3.0 allows attackers to perform XML signature wrapping attacks via unspecified vectors.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2016-5697?

2 open source packages ship an affected version, including ruby-saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby-saml` | RubyGems | All versions | 1.3.0 |
| `ruby-saml` | RubyGems | All versions | 1.3.0 |

Products: Onelogin Ruby-Saml.

## How do I fix CVE-2016-5697?

Upgrade ruby-saml to 1.3.0 or later.

## Is CVE-2016-5697 being exploited?

There is no known exploitation of CVE-2016-5697 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-20108](https://insights.sbomify.com/CVE-2015-20108/): ruby-saml vulnerable to XPath injection (critical 9.8)
- [CVE-2025-66567](https://insights.sbomify.com/CVE-2025-66567/): ruby-saml has a SAML authentication bypass due to namespace handling (parser differential) (critical 9.3)
- [CVE-2025-66568](https://insights.sbomify.com/CVE-2025-66568/): ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation (critical 9.3)
- [CVE-2017-11428](https://insights.sbomify.com/CVE-2017-11428/): Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5697 and fix it if it is affected.

What it is: CVE-2016-5697 is a high-severity vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5697 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby-saml (RubyGems): affected all versions; fixed in 1.3.0
- ruby-saml (RubyGems): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5697/ (Markdown: https://insights.sbomify.com/CVE-2016-5697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5697
- OSV: https://osv.dev/vulnerability/CVE-2016-5697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5697/
Summaries are generated and may contain mistakes; the official description above is the record.
