# CVE-2016-5702: phpMyAdmin cookie-attribute injection

> Remote attackers can inject cookie attributes via crafted URIs in phpMyAdmin when PHP_SELF is missing, potentially bypassing security controls.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-5702, GHSA-xqw9-ffx7-g998, UBUNTU-CVE-2016-5702

## What is CVE-2016-5702?

CVE-2016-5702 is a low-severity vulnerability in Phpmyadmin Phpmyadmin, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyAdmin 4.6.x before 4.6.3, when the environment lacks a PHP_SELF value, allows remote attackers to conduct cookie-attribute injection attacks via a crafted URI.

Weakness: CWE-254

## Which versions are affected by CVE-2016-5702?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 | 4.6.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6.0 | 4.6.3 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2016-5702?

Upgrade phpmyadmin/phpmyadmin to 4.6.3 or later.

## Is CVE-2016-5702 being exploited?

There is no known exploitation of CVE-2016-5702 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5702 and fix it if it is affected.

What it is: CVE-2016-5702 is a low-severity vulnerability in Phpmyadmin Phpmyadmin, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5702 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0; fixed in 4.6.3
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6.0; fixed in 4.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5702/ (Markdown: https://insights.sbomify.com/CVE-2016-5702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5702
- OSV: https://osv.dev/vulnerability/CVE-2016-5702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5702/
Summaries are generated and may contain mistakes; the official description above is the record.
