CVE-2016-5705 phpMyAdmin vulnerable to Cross-site Scripting
Remote attackers can inject arbitrary web script or HTML into phpMyAdmin via various input fields, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-5705?
CVE-2016-5705 is a medium-severity cross-site scripting vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.4.x before 4.4.15.7 and 4.6.x before 4.6.3 allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) server-privileges certificate data fields on the user privileges page, (2) an "invalid JSON" error message in the error console, (3) a database name in the central columns implementation, (4) a group name, or (5) a search name in the bookmarks implementation.
Weakness: CWE-79
Which versions are affected by CVE-2016-5705?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.3 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.3 |
Products include Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-5705?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.4.15.7 or 4.6.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-5705 being exploited?
There is no known exploitation of CVE-2016-5705 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Leap
Sources
Also known as DEBIAN-CVE-2016-5705, GHSA-6q2j-8h8q-46mr, UBUNTU-CVE-2016-5705.