CVE-2016-5706 phpMyAdmin Denial Of Service (DOS) attack
Remote attackers can cause a denial of service in phpMyAdmin by sending a large array in the scripts parameter.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-5706?
CVE-2016-5706 is a high-severity denial of service vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
js/get_scripts.js.php in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allows remote attackers to cause a denial of service via a large array in the scripts parameter.
Weakness: CWE-399
Which versions are affected by CVE-2016-5706?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.3 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.3 |
Products include Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-5706?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2016-5706 being exploited?
There is no known exploitation of CVE-2016-5706 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Leap
Sources
Also known as DEBIAN-CVE-2016-5706, GHSA-9rmm-8fp4-26hv, UBUNTU-CVE-2016-5706.