# CVE-2016-5725: Improper Limitation of a Pathname to a Restricted Directory in JCraft JSch

> A malicious SFTP server can write arbitrary files on Windows clients using JSch in overwrite mode via directory traversal in recursive GET responses.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-5725, DLA-2184-1, DLA-611-1, GHSA-q446-82vq-w674, MGASA-2016-0311, SUSE-SU-2017:0715-1

## What is CVE-2016-5725?

CVE-2016-5725 is a medium-severity path traversal vulnerability in n/a, published on 19 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in JCraft JSch before 0.1.54 on Windows, when the mode is ChannelSftp.OVERWRITE, allows remote SFTP servers to write to arbitrary files via a ..\ (dot dot backslash) in a response to a recursive GET command.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-5725?

2 open source packages ship an affected version, including com.jcraft:jsch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.jcraft:jsch` | Maven | All versions | 0.1.54 |
| `com.jcraft:jsch` | Maven | All versions | 0.1.54 |
| `jsch` | SUSE:Manager Server 3.0 | All versions | 0.1.54-3.1 |

Products: Jcraft Jsch.

## How do I fix CVE-2016-5725?

Upgrade com.jcraft:jsch to 0.1.54 or later.

## Is CVE-2016-5725 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-5725 exists.

Public exploit code:

- JCraft/JSch Java Secure Channel 0.1.53 - Recursive sftp-get Directory Traversal (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5725 and fix it if it is affected.

What it is: CVE-2016-5725 is a medium-severity path traversal vulnerability in n/a, published on 19 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-5725 exists.

Affected packages and fixed versions:
- com.jcraft:jsch (Maven): affected all versions; fixed in 0.1.54
- com.jcraft:jsch (Maven): affected all versions; fixed in 0.1.54

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5725/ (Markdown: https://insights.sbomify.com/CVE-2016-5725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5725
- OSV: https://osv.dev/vulnerability/CVE-2016-5725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5725/
Summaries are generated and may contain mistakes; the official description above is the record.
