CVE-2016-5730 phpMyAdmin full path disclosure vulnerability
Remote attackers can obtain sensitive information, including full file paths, via error messages triggered by malformed input in phpMyAdmin.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-5730?
CVE-2016-5730 is a medium-severity vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allows remote attackers to obtain sensitive information via vectors involving (1) an array value to FormDisplay.php, (2) incorrect data to validate.php, (3) unexpected data to Validator.php, (4) a missing config directory during setup, or (5) an incorrect OpenID identifier data type, which reveals the full path in an error message.
Weakness: CWE-200
Which versions are affected by CVE-2016-5730?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.3 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.3 |
Products include Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-5730?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.
Is CVE-2016-5730 being exploited?
There is no known exploitation of CVE-2016-5730 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Leap
Sources
Also known as DEBIAN-CVE-2016-5730, GHSA-wm9c-vcv2-vpqc, UBUNTU-CVE-2016-5730.