# CVE-2016-5730: phpMyAdmin full path disclosure vulnerability

> Remote attackers can obtain sensitive information, including full file paths, via error messages triggered by malformed input in phpMyAdmin.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-5730, GHSA-wm9c-vcv2-vpqc, UBUNTU-CVE-2016-5730

## What is CVE-2016-5730?

CVE-2016-5730 is a medium-severity vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allows remote attackers to obtain sensitive information via vectors involving (1) an array value to FormDisplay.php, (2) incorrect data to validate.php, (3) unexpected data to Validator.php, (4) a missing config directory during setup, or (5) an incorrect OpenID identifier data type, which reveals the full path in an error message.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-5730?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.16 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.16 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4 | 4.4.15.7 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4 | 4.4.15.7 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6 | 4.6.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.6 | 4.6.3 |

Products: Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2016-5730?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.

## Is CVE-2016-5730 being exploited?

There is no known exploitation of CVE-2016-5730 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Leap

- [CVE-2015-4902](https://insights.sbomify.com/CVE-2015-4902/): Oracle Java SE Integrity Check (medium 5.3, exploited in the wild)
- [CVE-2017-14804](https://insights.sbomify.com/CVE-2017-14804/): package builds could use directory traversal to write outside of target area (critical 9.9)
- [CVE-2019-20787](https://insights.sbomify.com/CVE-2019-20787/): Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size. (critical 9.8)
- [CVE-2019-8341](https://insights.sbomify.com/CVE-2019-8341/): Code injection in n/a (critical 9.8)
- [CVE-2019-6438](https://insights.sbomify.com/CVE-2019-6438/): Other in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-5730 and fix it if it is affected.

What it is: CVE-2016-5730 is a medium-severity vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-5730 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.16
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.16
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.7
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.7
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6; fixed in 4.6.3
- phpmyadmin/phpmyadmin (Packagist): affected from 4.6; fixed in 4.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-5730/ (Markdown: https://insights.sbomify.com/CVE-2016-5730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-5730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-5730
- OSV: https://osv.dev/vulnerability/CVE-2016-5730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-5730/
Summaries are generated and may contain mistakes; the official description above is the record.
