CVE-2016-5731 phpMyAdmin Cross-site scripting (XSS) vulnerability
Remote attackers can inject arbitrary web script or HTML via OpenID error messages in phpMyAdmin examples.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-5731?
CVE-2016-5731 is a medium-severity cross-site scripting vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in examples/openid.php in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allows remote attackers to inject arbitrary web script or HTML via vectors involving an OpenID error message.
Weakness: CWE-79
Which versions are affected by CVE-2016-5731?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.3 |
phpmyadmin/phpmyadmin Packagist | From 4.6 | 4.6.3 |
Products include Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-5731?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-5731 being exploited?
There is no known exploitation of CVE-2016-5731 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Leap
Sources
Also known as DEBIAN-CVE-2016-5731, GHSA-mwm8-36c5-j5cf, UBUNTU-CVE-2016-5731.