{"answers":{"affected":"6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.","exploited":"There is no known exploitation of CVE-2016-5731 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.","what":"CVE-2016-5731 is a medium-severity cross-site scripting vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-5731 and fix it if it is affected.\n\nWhat it is: CVE-2016-5731 is a medium-severity cross-site scripting vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-5731 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.16\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.16\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.7\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.7\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.6; fixed in 4.6.3\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.6; fixed in 4.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-5731/ (Markdown: https://insights.sbomify.com/CVE-2016-5731/index.md)","id":"CVE-2016-5731","markdown":"https://insights.sbomify.com/CVE-2016-5731/index.md","name":"CVE-2016-5731","record":{"aliases":["DEBIAN-CVE-2016-5731","GHSA-mwm8-36c5-j5cf","UBUNTU-CVE-2016-5731"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via OpenID error messages in phpMyAdmin examples.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"opensuse","vendor":"opensuse"},{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in examples/openid.php in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allows remote attackers to inject arbitrary web script or HTML via vectors involving an OpenID error message.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin Cross-site scripting (XSS) vulnerability","id":"CVE-2016-5731","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"opensuse:leap","products":["opensuse:leap","opensuse:opensuse","phpmyadmin:phpmyadmin"],"type":"xss","year":"2016"},"n_packages":6,"n_references":7,"next":{"headline":"phpMyAdmin XSS Vulnerability","id":"CVE-2016-5732"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.10.16"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-mwm8-36c5-j5cf"},{"ecosystem":"Packagist","fixed":["4.0.10.16"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-mwm8-36c5-j5cf"},{"ecosystem":"Packagist","fixed":["4.4.15.7"],"introduced":["4.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-mwm8-36c5-j5cf"},{"ecosystem":"Packagist","fixed":["4.4.15.7"],"introduced":["4.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-mwm8-36c5-j5cf"},{"ecosystem":"Packagist","fixed":["4.6.3"],"introduced":["4.6"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-mwm8-36c5-j5cf"},{"ecosystem":"Packagist","fixed":["4.6.3"],"introduced":["4.6"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-mwm8-36c5-j5cf"}],"prev":{"headline":"phpMyAdmin full path disclosure vulnerability","id":"CVE-2016-5730"},"products":["n/a"],"published":"2016-07-03","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.9,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2019-6438","kev_date_added":null,"published":"2019-01-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via OpenID error messages in phpMyAdmin examples.","url":"https://insights.sbomify.com/CVE-2016-5731/"}