CVE-2016-5733 phpMyAdmin vulnerable to Cross-site Scripting
Remote attackers can inject arbitrary web script or HTML into phpMyAdmin via various vectors, potentially leading to session hijacking or malicious actions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-5733?
CVE-2016-5733 is a medium-severity cross-site scripting vulnerability in Opensuse Leap, published on 3 Jul 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) a crafted table name that is mishandled during privilege checking in table_row.phtml, (2) a crafted mysqld log_bin directive that is mishandled in log_selector.phtml, (3) the Transformation implementation, (4) AJAX error handling in js/ajax.js, (5) the Designer implementation, (6) the charts implementation in js/tbl_chart.js, or (7) the zoom-search implementation in rows_zoom.phtml.
Weakness: CWE-79
Which versions are affected by CVE-2016-5733?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0.10.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.0.10.0 | 4.0.10.16 |
phpmyadmin/phpmyadmin Packagist | From 4.4.15.0 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.4.15.0 | 4.4.15.7 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.3 |
phpmyadmin/phpmyadmin Packagist | From 4.6.0 | 4.6.3 |
Products include Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-5733?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.16, 4.4.15.7 or 4.6.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-5733 being exploited?
There is no known exploitation of CVE-2016-5733 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Leap
Sources
Also known as DEBIAN-CVE-2016-5733, GHSA-cr65-p662-fx5c, UBUNTU-CVE-2016-5733.